[VMC on AWS] "Error loading Site Pairings Error: Unable to process HCX inventory details"
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[VMC on AWS] "Error loading Site Pairings Error: Unable to process HCX inventory details"

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Article ID: 313633

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Updated On:

Products

VMware Cloud on AWS

Issue/Introduction

To address the error: "Error loading Site Pairings Error: Unable to process HCX inventory details" that is received while trying to access site pairing/Interconnect tabs in HCX while logged in with an AD User Account.

Symptoms:
The below error : "Error loading Site Pairings Error: Unable to process HCX inventory details" is received while trying to access the site pairing in HCX while logged in with an Active Directory (AD) User Account.



Cause

The error is seen when user is logged in using credentials other than "[email protected]" or "[email protected]", typically an AD User Account.

Resolution

The logged in user needs to be a part of the vSphere role mapping designated in the management UI of HCX.
If tried Logging in with : [email protected]  credential, the error could  be resolved.

For successful login with AD credentials, the below mentioned points are to be taken care at:

a. On-prem :

Ensure the OnPrem HCX Manager's vSphere role mapping includes an AD Group that the target AD user account is a part of. This can be checked by following the below given steps:

  1. Login to the OnPrem HCX Manager VAMI - https://{HCX-FQDN}:9443
  2. Click Configuration
  3. Click vSphere Role Mapping

b. VMware Cloud: 

Ensure the SDDC vCenter's CloudAdminGroup includes an AD group that the target AD user account is a part of.
This documentation provides information on adding the AD group appropriately via an APIExplorer:

KB56489