[VMC on AWS] Best practices to follow while performing Hybrid Cloud Extension (HCX) Bulk Migrations
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Article ID: 313624
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Updated On:
Products
VMware Cloud on AWS
Issue/Introduction
This article provides best practices to be followed while performing HCX Bulk Migrations.
Symptoms:
Cause
Bulk Migration could fail due to the following reasons :
HCX is not upgraded to the latest version , incompatible versions between On-prem and Cloud.
When high capacity Virtual Machines(VM) using huge amount of memory are migrated concurrently, it can lead to HCX Bulk Migration failure.
The maximum capacity of concurrent migrations is 200 which is considered "Heavy".If the concurrent Migrations exceed the maximum capacity it can lead to Bulk Migration failure.
Resolution
Follow the given set of best practices for successful Bulk migrations :
It is a good practice to keep both the HCX versions (Onprem as well as Cloud ) upgraded to latest versions.
It is always advised to have an HCX inbound and outbound Rule in the SDDC.
The maximum concurrent migrations allowed is 200 which is considered “Heavy”.Thus it is recommended to not exceed this maximum number.
VMs with large disks and active database services that cause high data churn can significantly reduce the capacity of bulk migrations.
The recommendation is to limit the number of VM's depending on the size and load on the VMs to maximize the chances of successful migration and even then, if the change rate of data is too high compared to the available bandwidth and resources, the migration may not converge for which adjustments will have to be made to either shutdown database services prior to migration or opt for Cold migration.
It is advised not to use WAN optimization (WAN-OPT).WAN-OPT is designed technically if HCX is to be used over internet.
Workaround:
Additional Information
Bulk Migration: https://via.vmw.com/EUBj
Understanding the HCX vMotion and cold Migration: https://via.vmw.com/EUBk
For further queries on Bulk Migration reach out to VMware Chat Support or raise a Service Request with VMware Technical Support using the following document: https://kb.vmware.com/s/article/2006985