[VMC on AWS] While establishing Direct Connect(DX), Virtual Interface(VIF) attach option not showing up in DX UI
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Article ID: 313611
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Updated On:
Products
VMware Cloud on AWS
Issue/Introduction
The purpose of this document is to explain the VIF attachment process.
Symptoms: Connection between on-premises and SDDC is not possible if the VIF is not attached. The option of attaching VIF is not seen in the DX UI under the Network & Security Tab.
Cause
The VIF attach option is not showing up in DX UI because the private VIF was configured with the incorrect AWS Account ID.
Resolution
The private VIF allows vMotion, ESXi management, management appliance, and workload traffic to flow over the Direct Connect connection between on-premises environment and SDDC.
Steps to create private VIF
Log in to the AWS Console and complete the Creating a Hosted Private Virtual Interface
For the Interface Owner field, use the account shown in the AWS Account ID field of the Direct Connect page of the Networking & Security tab.
Select Auto-generate peer IPs and Auto-generate BGP key.
Interface Owner field should be populated with the AWS Account ID mentioned in the Direct Connect section of the Network & Security Tab of the desired SDDC.
When the interface has been created, the AWS console reports that it is ready for acceptance
In the VMC Console, select Networking & Security > Direct Connect and accept the virtual interface by clicking ATTACH.
Note: The DX needs to be in the same region as the SDDC for the VIF to be attached.