Error "Error downloading plug-in. Make sure that the URL is reachable and the registered thumbprint is correct. Unable to find certificate chain" is Seen When Downloading and Configuring Aria Operations Plugin in vCenter
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Error "Error downloading plug-in. Make sure that the URL is reachable and the registered thumbprint is correct. Unable to find certificate chain" is Seen When Downloading and Configuring Aria Operations Plugin in vCenter

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Article ID: 313551

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

Aria operations extension keep trying to download and failing with the following error in the vCenter Recent Task:

Error downloading plug-in. Make sure that the URL is reachable and the registered thumbprint is correct. Unable to find certificate chain.

Plugin Server: ##.###.#:443/vrops-unicorn/plugin.zip

Instance Version: 8.18.x

Status: Failed

VMware certified: Unknown

 

Environment

  • Aria Operations 8.18.x

Cause

Below are causes of the issue: 

1. Aria Operations is migrated to a different vCenter.
2. Aria Operations is upgraded
3. Certifcate thumbprint for Plugin Server certificate is not updated in vCenter MOB. 

Resolution

First, Validate if the Certificate thumbprint is rightly updated in vCenter mob. 

Execute steps below for the same: 

1. SSH to the Plugin Server as "root". 
2. Run the command below and copy certificete thumbprint: 

# openssl s_client -connect <Cloud_Proxy_Address>:443 | openssl x509 -fingerprint -sha256 -noout -in /dev/stdin...sha256 

3. Run below URL in the browser to get thumbprint in Mob for the Plugin Server: 

 

If there is mismatch between Thumbprint Step 2 and Step 3, please create a case with technical support and mention the KB number. 

If the issue occurs after migration:

  • In the Aria operations UI, verify and delete the old vCenter instance which is not in use.
  • Then check the New VMC adapter instance and test the Connection if it's successful then unregister and register back again.

If the error occurs after upgrade:

  • First unregister the vCenter adapter from Aria Operations.
  • Once the unregister is complete, manually remove the 8.18 plugin (if it remains).
  • Then register the plugin again from the adapter. This should push the most recent version

 If the above resolution does not resolve the issue open a case with technical support and mention this KB number

Note: The following KB can also be followed to simply remove the Aria Operations Plugin extension and re-configure the Plugin in Aria Operations > Data Sources > Integrations > vCenter > Edit > Manage Registrations (in 8.17.x and earlier versions) and Aria Operations > Administration > Integrations > vCenter > Edit > Manage Registrations (in 8.18.x versions):