Connect vRealize Log Insight to Domain fails
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Connect vRealize Log Insight to Domain fails

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Article ID: 313493

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Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

Symptoms:

After vRealize Log Insight version 8.8 is deployed via vRSLCM in the SDDC Manager UI it may fail the "Connect vRealize Log Insight to Domain X" workflow at the "Install vRealize Log Insight Content Packs for Management Domain" task and in the /var/log/vmware/vcf/domainmanager/domainmanager.log log file you can find the snippet:
Content Pack with requested namespace( list ) not found


Note that the problem is present for Log Insight version 8.8 which is deployed on VCF 4.4.* and for Log Insight version newer than 8.10.* which is deployed on VCF 4.5.1


Environment

Vmware Cloud Foundation 4.5.1
VMware Cloud Foundation 4.4
VMware Cloud Foundation 4.4.1

Cause

The is due to the Automation bug.

Resolution

Currently there is no resolution. The issue will be fixed in the future releases.

Workaround:

To workaround the issue, please follow the below mentioned steps:

  1. Open the vRealize Log Insight UI.
  2. Navigate to Content Packs -> Marketplace
  3. Install the following packs (or the latest available of them):
  • Linux
  • Linux - Systemd
  • VMware-vRSLCM-8.0.1+
  • VMware - NSX-T (latest renamed to VMware - NSX)
  • VMware - vROps 6.7+ (if vRealize Operations is deployed)
  • VMware - vRA 8.3+ (if vRealize Automation is deployed)
  • VMware - vRO 8.0+ (if vRealize Automation is deployed)
  1. SSH to SDDC Manager VM, enable the root user and run the command:

psql -h localhost -U postgres -d platform -c "UPDATE domain SET vrli_integration_status = 'ENABLED' WHERE type = 'MANAGEMENT';"

Note: Once the workaround is applied and the content packs are visible in vRLI UI, the issue is resolved however VCF task will continue to be in ERROR state, this can be safely ignored.