VMware Cloud Foundation: ESXi Upgrade bundle validation check or upgrade fails
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VMware Cloud Foundation: ESXi Upgrade bundle validation check or upgrade fails

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Article ID: 313427

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Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

To know the reason where the scan failure on ESXi host occured.

Symptoms:
Scan for some hosts fails during precheck or upgrade.


 
 
 


Environment

VMware Cloud Foundation 4.x
VMware Cloud Foundation 5.0

Cause

The cause for scan can be one of the possible reasons below. To know the exact reason of failure please follow the resolution below

  • Unsupported CPU    

  • Error in staging storage    

  • Error in boot partition

  • Incompatible GRUB configuration    

  • Incompatible ESX configuration    

  • Error in inventory file    

  • Unsupported boot storage    

  • Unsupported boot device    

  • Unsupported agents    

  • Unsupported services    

  • Unsupported configuration

  • Unsupported devices {precheckError} found on the host.

  • Insufficient memory, minimum {precheckError}MB required for upgrade.

  • Unsupported boot disk

  • Active directory must be disabled

  • The upgrade precheck script returned unknown error.

  • The upgrade has a missing package for host {host} of type {type}.

  • Host version {version} is not supported for this upgrade.

  • Host version {version} is not supported for this upgrade. Supported host versions are: {hostRecommendations}.

  • Upgrade to the same version is not supported.

  • Upgrade is not applicable for host {host} with version {version}.

  • The host partition layout is not suitable for upgrade.

  • The host does not have sufficient space on boot partition to store the upgrade image. A minimum of {precheckError}MB is required. Retry after freeing up sufficient space or perform a CD-based installation.

  • Cannot create a ramdisk of size {precheckError}MB to store the upgrade image. Check if the host has sufficient memory.

  • The host does not have sufficient free space on a local VMFS datastore to back up current host configuration.  A minimum of <size> MB is required.

  • The host uses a non-standard password encryption scheme.

  • Software modules {precheckError} published by third party vendor(s) are installed on the host. Upgrading the ESXi host will remove these modules.

  • The upgrade will remove the Cisco Nexus 1000V virtual network switch feature from the host.

  • The host uses an EMC PowerPath multipathing module {precheckError} to access storage. The host will not be able to access such storage after upgrade.

  • The host is currently added to a Cisco Nexus 1000V virtual network switch. The upgrade contains a Cisco Nexus 1000V software package {vib} that is incompatible with the Cisco Nexus 1000V VSM. Upgrading the host will remove the feature from the host.

  • The host is currently added to a Cisco Nexus 1000V virtual network switch. The upgrade does not contain any Cisco Nexus 1000V software package that is compatible with the Cisco Nexus 1000V VSM. Upgrading the host will remove the feature from the host.

  • The upgrade contains a Cisco Nexus 1000V software package {vib} that is incompatible with the Cisco Nexus 1000V software package on the host. Upgrading the host will remove the feature from the host.

  • The upgrade image {profileName} does not contain any Cisco Nexus 1000V software package that is compatible with the Cisco Nexus 1000V software package on the host. Upgrading the host will remove the feature from the host.

  • Host upgrade validity checks for {precheckError} are not successful.

  • Cannot determine whether the upgrade breaks Cisco Nexus 1000V virtual network switch feature on the host. If the host does not have the feature, you can ignore this warning.

  • Host software configuration requires a reboot. Reboot the host and try to upgrade again.

  • VMkernel and Service Console network interfaces are sharing the same subnet {subnet}. This configuration is not supported after upgrade. Only one interface should connect to subnet {subnet}.

  • New ESXi version requires a minimum of {expected} processor cores.

  • Processor does not support hardware virtualization or it is disabled in BIOS. Virtual machine performance may be slow.

  • The root password is not using MD5 hashing, causing it to be authenticated up to only 8 characters. For instructions on how to correct this, please refer ESX 4.1 and ESXi 4.1 root passwords are authenticated up to only 8 characters.

  • Host CPU is unsupported. New ESXi version requires a 64-bit CPU with support for LAHF/SAHF instructions in long mode.

412 com.vmware.vcIntegrity.HostUpgrade.NxbitEnabled=No eXecute (NX) bit is not enabled on the host. New ESXi version requires a CPU with NX/XD bit supported and enabled.
  • The upgrade contains the following set of conflicting VIBs:

{precheckError} Remove the conflicting VIBs or use Image Builder to create a custom upgrade ISO image that contains the newer versions of the conflicting VIBs, and try to upgrade again.
  • The CPU for host: {host} is not supported. Host cannot be upgraded.

  • The upgrade has VIBs that are missing dependencies:

{precheckError} Remove the VIBs or use Image Builder to create a custom upgrade ISO image that contains the missing dependencies, and try to upgrade again.
416 com.vmware.vcIntegrity.HostUpgrade.NativeNic=The system image on the attached iso lacks a NIC driver for the management network traffic.
  • The system image on the attached iso lacks a storage driver for the installed bootbank.

  • The version of ESXi you are attempting to upgrade with does not support legacy FT anymore. Turn off legacy FT on virtual machines in the cluster.

  • One or more VMFS3 volumes have been detected on host {host}. Use the vSphere Web Client to upgrade the VMFS3 volumes to VMFS5. For instructions on how to upgrade a datastore to VMFS5, see the vSphere Storage guide.

  • The upgrade is not supported on the host hardware. The upgrade ISO image contains {code} VIBs that failed the host hardware vendor compatibility check. VIBs by {code} are not supported on host hardware model {model} made by vendor {vendor}.

  • The upgrade is not supported on the host hardware. The upgrade ISO image contains {code} VIBs that failed the host hardware model compatibility check. VIBs by {code} are not supported on host hardware model {model} made by vendor {vendor}.

  • The upgrade package is not compatible with the host. Use an upgrade package that meets the host's acceptance level or change the host's acceptance level to match that of the upgrade package.

  • The system has insufficient locker space for the image profile.

  • The boot disk has a size of {found}MB, the minimum requirement of the upgrade image is {expected}MB.

  • ESXi host is not ready for NSX-T vSphere Distributed Switch (VDS) migration included with this ESXi upgrade. Please run Upgrade Readiness Tool (URT) from the NSX-T Manager managing this host.

  • TPM 1.2 device detected. Support for TPM version 1.2 is discontinued. Installation may proceed, but may cause the system to behave unexpectedly.

  • The host is managing a DPU(s) and is a part of vLCM baselines-managed cluster, which is not supported. Move the host to vLCM image-managed cluster and try again.

  • These VIB(s) on the host do not have the required sha-256 checksum for their payloads:

{precheckError} This will prevent VIB security verification and secure boot from functioning properly. Please remove these VIBs and check with your vendor for a replacement of these VIBs.

Resolution

To know the exact reason of scan failure, please follow the below mentioned steps:

  1. On vCenter UI in inventory, on corresponding host click monitor and view tasks. It will show the recently run scan task here.
  2. Expand the scan task to view the message related to error.
  3. Follow the instructions in the message to resolve the error and retry the ESXi upgrade/pre-check from VCF.