Resolving DSM Installation Issues: Troubleshooting DSM plugin 'Install Solution' task fails or times out
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Resolving DSM Installation Issues: Troubleshooting DSM plugin 'Install Solution' task fails or times out

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Article ID: 313175

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:
The vCenter DSM plugin 'Install Solution' task fails or times out.

Cause

The DSM appliance registers with the vCenter Extension Manager during its first boot. When this registration fails, the 'Install Solution' task created by vCenter times out and fails while waiting for the registration call from the DSM appliance.

Check Network Connectivity

  • The vCenter selected in the 'Associate vCenter' step in the deployment wizard must be reachable from the DSM appliance with successful DNS resolution.
  •  The DSM appliance IP must be reachable from the vCenter which is selected for association.
  • If the vCenter FQDN supplied during deployment ends with '.local', then DNS resolution would be attempted locally using the appliance's /etc/hosts file. In such cases, add the DNS entry of the FQDN to the /etc/hosts file.


 

Resolution

To resolve the issue, manual plugin registration from the appliance can be attempted.

After correcting the required network connectivity, follow the below mentioned steps for manual plugin registration:

  1. SSH into the DSM appliance

  2. Execute the manual registration command,

# Target vc details for plugin registration
vc_host=<vc-host>
vc_admin_username=<vc-sso-admin-username>
vc_admin_password=<vc-sso-admin-password>

 

# Plugin Registration commmand
dsm_ip=$(ip route get 1 | awk '{print $(NF-2);exit}') && \
vc_tp=`openssl s_client -connect $vc_host:443 < /dev/null 2>/dev/null | openssl x509 -fingerprint -noout -in /dev/stdin -sha256 | sed "s/sha256 Fingerprint=//g"` && \
dsm_tp=`openssl s_client -connect $dsm_ip:443 < /dev/null 2>/dev/null | openssl x509 -fingerprint -noout -in /dev/stdin -sha1 | sed "s/sha1 Fingerprint=//g"` && \
dsm_version=`cat /etc/vmware/cap/product.info  | jq --raw-output ' .version '` && \
docker_img=$(docker images --format "{{.Repository}}:{{.Tag}}" | grep "extension-registration") && \
docker run $docker_img \
-action registerPlugin -remote \
-url https://$vc_host/sdk -vct $vc_tp \
-username $vc_admin_username -password $vc_admin_password \
-key com.vmware.dsm.plugin -version $dsm_version \
-pluginUrl https://$dsm_ip/provider/plugin/plugin.json -serverThumbprint $dsm_tp \
-c 'VMware, Inc.' -n 'Data Services Manager Plugin' -s 'Data Services Manager Plugin'


If the problem persists, please collect the support bundle by executing below command. This would help in troubleshooting your issue.
`sh /opt/vmware/tdm-provider/provider_logbundle.sh <logbundle_filename_without_ext> <logbundle_folder>`
Example:
`sh /opt/vmware/tdm-provider/provider_logbundle.sh logbundle_postboot /data`


Additional Information

Note: This KB is only applicable to DSM version 2.0.0 and 2.0.1