"The available Memory resources in the parent resource pool are insufficient for the operation" powering on Virtual Machine
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"The available Memory resources in the parent resource pool are insufficient for the operation" powering on Virtual Machine

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Article ID: 313068

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Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

This article provides information on how to troubleshoot and fix a VM with the error The available Memory resources in the parent resource pool are insufficient for the operation.

Symptoms:
  • Powering on a virtual machine (VM) fails with the error:

The available Memory resources in the parent resource pool are insufficient for the operation

  • VMs cannot power on the ESXi host selected


Note: Changing VM memory resource settings may affect the performance of the VM's guest operating system or applications.


Environment

VMware vSphere ESXi 6.7
VMware vCenter Server Appliance 6.5.x
VMware vCenter Server Appliance 6.0.x
VMware vCenter Server 7.0.x
VMware vSphere ESXi 6.5
VMware vCenter Server 6.5.x
VMware vCenter Server Appliance 6.7.x
VMware vCenter Server 6.0.x
VMware vCenter Server 6.7.x
VMware vSphere ESXi 6.0
VMware vSphere ESXi 7.0.0

Cause

Some potential causes for The available Memory resources in the parent resource pool are insufficient for the operation include:
  • VM memory reservation settings higher than the ESXi host can support
  • VM configuration information is corrupted in the ESXi/vCenter database
  • ESXi OS problem
  • vCenter Server OS problem
  • vCenter/ESXi host communication problem
  • ESXi host server hardware configuration problem

Resolution

Verify the virtual machine and ESXi host memory resources

  1. Check the memory reservation settings for the VM.
  2. Check the memory availability for the ESXi host managing the VM.

If there are no memory constraints seen

  1. Connect directly to the ESXi host client for the host managing the VM and recheck the settings

    • If the memory in the ESXi host client here are different than in the vCenter Server UI
      1. Rule out a problem in the vCenter Server OS by restarting the vCenter Server and if applicable Platform Services Controller (PSC)
      2. If rebooting vCenter fails to fix the problem, there may be a communication problem between the vCenter Server and the ESXi host.
  • Or make the configuration changes using the ESXi host client
  1. If the settings still make no sense even from the ESXi client, the VM's information may have corrupted.
  1. Unregister the VM from vCenter UI if you can, ESXi client level if you cannot
  2. Re-register the VM, see How to register or add a Virtual Machine (VM) to the vSphere Inventory in vCenter Server

If the numbers indicate there is a problem with the memory reservation:

  • Remove or reduce the reservation
  • Or, Increase the ESXi host's resources or move the VM to another host with adequate resources
To remove or reduce the reservation:
  1. Locate the affected VM
  2. In the vSphere Client, right-click the virtual machine and click Edit Settings..
  3. Click the Resources tab.
  4. Reduce the reserved CPU/memory value or set it to 0 to remove the reservation.
  5. Click OK. The virtual machine reconfigures and you should no longer see the alert in the Summary tab.

If there you encounter issues reconfiguring the failover reservation, ensure your ESXi hosts are patched to ESXi 6.0 Update 3 or later as there are fixes for VM memory resource problems.

If you have performance problems with the required changes:

  • Add more resources to the hosts to allow you to increase the memory resource as before
  • Or, consult with your application or guest OS vendor


Additional Information