VM power-on fails with "The available Memory resources in the parent resource pool are insufficient for the operation"
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Article ID: 313068
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Updated On:
Products
VMware vCenter ServerVMware vSphere ESXi
Issue/Introduction
When trying to power on a virtual machine (VM) in vSphere Client, the task fails with an error message:
The available Memory resources in the parent resource pool are insufficient for the operation
When using the ESXi host client instead, the power on operation fails with a similar error.
Environment
VMware vSphere ESXi 6.x
VMware vSphere ESXi 7.0.x
VMware vSphere ESXi 8.0.x
VMware vCenter Server 6.x
VMware vCenter Server 7.0.x
VMware vCenter Server 8.0.x
Cause
Some potential causes for the issue can include:
VM memory reservation settings higher than the ESXi host can support
VM configuration information is corrupted in the ESXi/vCenter database
ESXi OS problem
vCenter Server OS problem
vCenter/ESXi host communication problem
ESXi host server hardware configuration problem
Resolution
Verify the virtual machine and ESXi host memory resources
Check the memory reservation settings for the VM. Reserved resources are not subject to ESXi scheduling / memory reclamation and must be available in the physical memory of the host
Confirm that the ESXi the VM is registered on has enough free memory to accommodate the VM.
Check if the virtual machines is part of a resource pool and confirm that the resource pool has enough free memory
If there are no memory constraints seen
Connect directly to the ESXi host client for the host managing the VM and recheck the settings
If the memory in the ESXi host client here are different than in the vCenter Server UI
Rule out a problem in the vCenter Server OS by restarting the vCenter Server and if applicable Platform Services Controller (PSC)
If rebooting vCenter fails to fix the problem, there may be a communication problem between the vCenter Server and the ESXi host.
If the numbers indicate there is a problem with the memory reservation:
Remove or reduce the reservation
Alternatively, increase the ESXi host's resources or move the VM to another host with adequate resources
To remove or reduce the reservation:
Locate the affected VM
In the vSphere Client, right-click the virtual machine and click Edit Settings..
Under "Virtual Hardware" expand "Memory" and "CPU"
Reduce the reserved CPU/memory value or set it to 0 to remove the reservation.
Click OK. The virtual machine reconfigures and you should no longer see the alert in the Summary tab.
If you have performance problems with the required changes:
Add more resources to the hosts to allow you to increase the memory resource as before
Or, consult with your application or guest OS vendor
Additional Information
Please keep in mind that changing the resource configuration of a virtual machine can impact its performance
The issue can also occur if the Latency Sensitivity of a virtual machine is set to HIGH, as this requires the complete VM memory (and CPU) to be reserved. Refer to Configure the Virtual Machine Latency Sensitivity