Corrupt redo log causes errors within the virtual machine while powering on ESXi
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Corrupt redo log causes errors within the virtual machine while powering on ESXi
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Article ID: 313052
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Updated On: 02-06-2025
Products
VMware vSphere ESXi
Issue/Introduction
Symptoms:
When the virtual machine in ESXi is powered on, you see the error: msg.hbacommon.corruptredo:The redolog of vmname-000001.vmdk has been detected to be corrupt. The virtual machine needs to be powered off. If the problem still persists, you need to discard the redolog.
msg.hbacommon.corruptredo:The redo log of vmname-000001.vmdk is corrupted. If the problem persists, discard the redo log
Note: This prompt is an endless loop. The error will display repeatedly if you click OK.
Powering off the virtual machine, you see an error: The attempted operation cannot be performed in the current state
Cause
File corruption is random in nature.
This issue might occur by various circumstances that include but are not limited to:
Hardware issues with the storage controller or storage device.
Connectivity issues between the ESX host and the storage device.
When the datastore containing the snapshot disks runs out of free disk space.
Resolution
To resolve this issue, use one of the options based on the symptom you are experiencing:
Create enough free space on the datastore where the snapshot disks are located:
Extend the particular VMFS datastore.
Migrate other virtual machines' files out of this datastore.
Commit the virtual machine snapshots:
Verify that you have enough free space before proceeding.
If the snapshot configuration files are corrupt and do not display in Snapshot Manager, consolidate the snapshot disks manually by taking another snapshot manually.
If the clone operation fails with a device or resource busy error message, the virtual machine is not powered off completely. You might see the error: msg.hbacommon.corruptredo
Click OK to power off the virtual machine and continue.
If the virtual machine is unable to proceed past this error, the virtual machine world must be terminated manually. Note: Manually terminating the virtual machine world ID terminates the virtual machine's processes. For more information, see Powering off an unresponsive virtual machine on an ESX host (308457). Go to step 2 or power on the virtual machine according to the current status.
Note: If unable to consolidate the snapshots, the virtual machine has to be restored from last good backup. For assistance, file a technical support request with VMware Technical Support. For more information, see Creating and managing Broadcom support cases
Additional Information
Note: The corrupt redo log message just indicates that the in-memory delta disk metadata was not in-sync with on-disk metadata when the storage snapshot was taken or at the time when LUN replication was stopped.