"The VMRC Console has Disconnected. Trying to reconnect" error while Connecting to a virtual machine console
book
Article ID: 313017
calendar_today
Updated On:
Products
VMware vSphere ESXiVMware vCenter Server
Issue/Introduction
Symptoms:
Attempting to connect to a virtual machine console fails.
The VMRC session opens with the vSphere Web Client, but not with the vSphere Client.
You see the error :
Error: The VMRC Console has Disconnected.. Attempting to reconnect
Environment
VMware vSphere ESXi 6.x
VMware vCenter Server 6.x
VMware vSphere ESXi 7.x
VMware vCenter Server 7.x
VMware vSphere ESXi 8.x
VMware vCenter Server 8.x
Cause
This issue occurs due to an Application Control software such as antivirus software that blocks certain applications or functions of installed software on client/server systems.
Note: Access to Web GUI of the security server or hosted portal is important to disable certain settings depending on antivirus architecture.
Resolution
To resolve the error "The VMRC Console has Disconnected. Trying to reconnect", use one of these options:
Disable application control for virtual applications through the antivirus software.
The exact means and methods to disable are specific to the antivirus software. Please consult your antivirus vendor for assistance if needed.
Uninstall and reinstall the vSphere Client. When doing this, please ensure any older versions of the client are uninstalled. In some cases, use of a registry cleaner may even be necessary.
Stop the vmware-vmrc.exe*32 service from Windows Task Manager and log in again.
If this issue persists, file a Support Request with Broadcom Support