Resetting/Unlocking admin & root account passwords on vSphere Replication & Site Recovery Manager
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Resetting/Unlocking admin & root account passwords on vSphere Replication & Site Recovery Manager

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Article ID: 312789

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Updated On:

Products

VMware Live Recovery VMware vSphere ESXi

Issue/Introduction


GNU GRUB menu contains slight changes due to a change of operating system from SUSE Linux to Photon OS.

Environment

VMware Site Recovery Manager 8.x
VMware vSphere Replication 8.x
VMware vSphere Replication 9.x
VMware Live Site Recovery

Cause

  • Root password for vSphere Replication (VR) appliance is not known by the administrator.
  • vSphere Replication root password is lost or is locked.

Resolution

  • Shutdown vSphere replication appliance from vSphere client
  • Delay the boot sequence of the VM 
  • Power on vSphere replication appliance. When the Photon OS splash screen appears, press 'e' to enter GNU GRUB edit menu

  Note:  The Photon OS splash screen only appears very briefly, so be quick about it. It is better to use VMware Remote Console rather than the Web Console

   
 
  • In the GNU GRUB edit menu, go to the end of the line that starts with linux, add a space and type rw init=/bin/bashAfter adding these values, GNU GRUB edit menu should look exactly like this:
 
   

   For 8.4 the screen will look different  

   

   VLSR9.X

  init=/bin/bash

   

  • Press the F10 key to boot and at the bash command prompt mount the root partition 
           mount -o remount, rw /
  • Enter passwd then enter to change the password
passwd
 
New password: <enter new password>
 
Retype new password: <repeat password>
 
passwd: password updated successfully ​​​
 
Note : The above will change only root password, if you need to change admin password need to perform additional steps as below
 
passwd admin
 
New password: <enter new password>
 
Retype new password: <repeat password>

 

    passwd: password updated successfully 

​​​
         

  • If admin account password is locked, VAMI page for appliance will fail to login,

  • For product version 8.8 and above you will check and clear the lock with the following command

    pam_tally2 -u root ----->If locked run: 
    /sbin/pam_tally2 -r -u root
    
    pam_tally2 -u admin ----->If locked run:
    /sbin/pam_tally2 -r -u admin
  • For product  version 8.8 and VLSR 9.x use the command 

    faillock --user root  ----->If locked run:
    /sbin/faillock --user root --reset 
    
    faillock --user admin  ----->If locked run:
    /sbin/faillock --user admin --reset   
  • At the command prompt, unmount the file system using the below command

      umount / 
 

  • Reboot the appliance 

         reboot -f 
 

  • After the VLSR appliance reboots, log in with the new root password

Additional Information