VLSR - Launching SRM plug-in from vCenter displays the message - A server error occurred
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VLSR - Launching SRM plug-in from vCenter displays the message - A server error occurred

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Article ID: 312761

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:

When we launch SRM UI from vCenter, we see the error 

https://192.X.X.3/dr/authentication/websso/webssologin
A server error occurred
Check the server logs for more details.
 

A server error occurred
HTTP error code: 400, status: BadResponse, sub status: No authentication request found matching InResponse To attribute of SAML Response from IDP..

 

 

 

/var/log/vmware/dr-client/dr.log :

2023-11-06 12:15:16,834 [srm-reactive-thread-125] WARN com.vmware.srm.client.infrastructure.http.BaseAsyncController 6b122e2d-121e-4148-8c85-e99004c0e13a - Request for path 'webssologin' failed.

com.vmware.srm.client.topology.impl.vmomi.TokenProvider$AcquireTokenFailed: Unable to acquire token from SSO Server at 'https://vcenter.vmware.local/sso-adminserver/sdk/vsphere.local'.

Caused by: com.vmware.vim.sso.client.exception.InternalError: Failed trying to retrieve token: ns0:RequestFailed: EndTime: Mon Nov 06 18:10:50 GMT 2023 is not after startTime: Mon Nov 06 18:15:16 GMT 2023

vmware-identity-sts.log : 

2023-11-06T18:07:05.695Z INFO sts[62:tomcat-http--26] [CorId=66c479a3-7d97-4f17-8126-ef9fdb4b46fd] [com.vmware.identity.sts.ws.SOAPFaultHandler] Returning a SOAP Fault with code: ns0:RequestFailed and description: EndTime: Mon Nov 06 18:10:50 GMT 2023 is not after startTime: Mon Nov 06 18:15:16 GMT 2023

/var/log/vmware/vmware-dr.log:

2024-11-09T13:39:51.365Z info vmware-dr[02139] [SRM@6876 sub=Listener.HTTPService.HttpConnection opID=29cbdf4f-login] HTTP Connection read failed while waiting for further requests; <io_obj p:0x00007f92b002ad48, h:-1, <UNIX '/run/vmware/srm/srm-socket'>, <UNIX ''>>, N7Vmacore16TimeoutExceptionE(Operation timed out: Stream: <io_obj p:0x00007f92b002ad48, h:-1, <UNIX '/run/vmware/srm/srm-socket'>, <UNIX ''>>, duration: 00:00:45.448962 (hh:mm:ss.us))



Environment

VMware Site Recovery Manager 8.x

Cause


Time is not in sync between the appliances (VR, SRM & vCenter/PSC)

Resolution

1. Ensure the time is synced between vSphere Replication, SRM & vCenter 
2. If step 1 is correct but its still not working - Try moving all 3 nodes (VR,SRM & VC) to one host. 
3. Restart VR & SRM UI and check 

systemctl restart tomcat  (UI in VRMS)
systemctl restart dr-client(UI in SRM)

For example:
  • Open a VAMI session the SRM appliance and the associated vCenter appliance (x.x.x.x:5480)
  • Under TIME on the vcenter VAMI page, note the NTP server(s) and ensure they are IDENTICAL and in EXACT SAME ORDER on the SRM appliance If not, copy them and add them to the VR/SRM appliance so both are the same.
  • Check the TIME ZONE and ensure it matches the time displayed.  If VC is using UTC, then the time zone should say "UTC" not "etc/UTC"  Change the time zone if necessary.
  • Under TIME ZONE on the SRM appliance, ensure it matches the server time displayed. (or set it to the desired time zone) If the time is set to PST, then the TIME ZONE should read "US PACIFIC"
  • After checking DNS and NTP go under SUMMARY on the SRM VAMI and click on RECONFIGURE to reconnect to the vcenter server.
  • Repeat this procedure for the VRMS/vSphere Replication Appliance (if applicable)

Additional Information

Impact/Risks:


You cannot manage SRM if the UI is not working.