SRM - There are not enough licenses installed to perform the operation
search cancel

SRM - There are not enough licenses installed to perform the operation

book

Article ID: 312725

calendar_today

Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:


SRM displays the error below when performing some operations listed here  -

ERROR
Operation Failed
There are not enough licenses installed to perform the operation.
12/1/22, 12:29:43 PM -0700

  1. When the current SRM license key has expired
  2. Protecting an existing VM in Protection Group
  3. Adding a new VM to Protection Group
  4. Performing a failover, failback or re-protect activity 

NOTE : Site Recovery Manager preserves the license only during an upgrade within the same version, for example, from version 8.3.0.x to version 8.3.1, or from version 8.4.0.1 to version 8.4.0.2. During an upgrade to a different version, for example, from 8.4 to 8.5 or later, Site Recovery Manager reverts to an evaluation license. After the upgrade, you must reinstall your Site Recovery Manager license key.

Information That Site Recovery Manager Upgrade Preserves


Environment

VMware Site Recovery Manager 8.x

Cause

  1. Multiple SRM solutions found under vCenter Licenses > Assets > Solutions
  2. Improper license key assigned to the SRM solution
  3. Insufficient license assigned to the SRM solution
  4. SRM solution is still running with an evaluation key (Appropriate license key is still not assigned to SRM solution)
  5. Check if the license key has a hard limit on the number of CPUs or VMs it can protect and whether you are hitting that limit, in which case you may have to procure a new license key or talk increase the limit of the existing license by talking to your sales rep or VMware license team. 

image.png

Resolution


NOTE: The following steps must be performed on Production & Recovery sites.
 

  1. Remove all the SRM solutions from vCenter Licenses > Assets > Solutions
  2. Restart srm-server service (Appliance) OR VMware vCenter Site Recovery Manager Server service (Windows); doing this will allow SRM solution to repopulate in vCenter.
  3. If step 2 fails - Reconfigure SRM (Appliance) OR run a modify install (Windows) for SRM to re-register its solution with vCenter.
  4. Assign a valid SRM license key to the solution, this should resolve the issue.