SRM protection group is showing as Not Configured after upgrading SRM & VRMS
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SRM protection group is showing as Not Configured after upgrading SRM & VRMS

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Article ID: 312712

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:

This issue is observed in vSphere Replication 8.7

  • SRM Appliance:/var/log/wmware/srm/vmware-dr.log
YYYY-MM-DDTHH:MM:SSZ verbose vmware-dr[02220] [SRM@6876 sub=LocalHms connID=hms-admin-db78] ConnectLocked: Attempting to connect
YYYY-MM-DDTHH:MM:SSZ verbose vmware-dr[02191] [SRM@6876 sub=IO.Connection] Attempting connection; <resolver p:0x00007f876808bed0, 'VRMS.server.local:8043', next:<TCP '192.X.X.21 : 8043'>>, last e: 0(Success)
YYYY-MM-DDTHH:MM:SSZ warning vmware-dr[02185] [SRM@6876 sub=LocalHms connID=hms-admin-db78] Failed to connect:
--> N7Vmacore4Http13HttpExceptionE HTTP error response: Bad Request. Reason: <!doctype html><html lang="en"><head><title>HTTP Status 400 – Bad Request</title><style>



Environment

VMware vSphere Replication 8.x

Cause


VRMS(HMS) hostname uses Upper and lower case.
For example: VRMS.server.local

Resolution


This issue is fixed in vSphere Replication 8.8

Workaround:

Changing VRMS(HMS) hostname to lower case and regenerated the certificate with lower case in VAMI, then reconfigured the appliance using lower case FQDN. Issue resolved.