Site Recovery Manager fails to deploy IP Customization package on certain VMs running Tools 10.1.x or higher
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Site Recovery Manager fails to deploy IP Customization package on certain VMs running Tools 10.1.x or higher

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Article ID: 312673

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Updated On:

Products

VMware Live Recovery

Issue/Introduction


With the introduction to VMWare Tools 10.1.x and up, the method of transferring customization scripts has changed. In prior versions, the transport method was for the Site Recovery Manager server to transfer this data to vCenter and subsequently the Host who is running the Virtual Machine that is being IP customized.

With the new Tools version, this has changed to a more concise transport, which cuts out vCenter server in the transport. Now, Site Recovery Manager, transfers IP Customization scripts directly to its local Hosts, running the Virtual Machine that needs IP Customization.

Symptoms:
  • IP Customizations fail on certain VMs using newer VM Tools, version 10.1.x and above.
  • In SRM Logs, after a failure is seen, you find log lines that match the following:
Received SOAP response fault from [<cs p:000000fe6f2a8020, TCP:esxi_hostname.customer_domain.org:443>]: fileManagement An error occurred while communicating with the remote host. An error occurred while communicating with the remote host.


Cause


Due to this change, port 443 is required to be open between Site Recovery Manager and the local hosts on the site it manages. Without this port being open, IP Customization will fail for VMs running Tools 10.1.x and above.

Resolution

Ensure port 443 is open between Site Recovery Manager and to the hosts that it manages for recovery.

Additional Information

Note: This port may not be listed on our KB articles that specify required ports for Site Recovery Manager. As of this KB is being written, the process of updating these articles is in progress.