Following an upgrade to NSX-T 4.1.1, index is of sync
search cancel

Following an upgrade to NSX-T 4.1.1, index is of sync

book

Article ID: 312634

calendar_today

Updated On:

Products

VMware NSX Networking

Issue/Introduction

Symptoms:
  • Following an upgrade to NSX-T 4.1.1, Index is out of sync.
  • "start search resync all" has been executed on all the NSX-T Manager Nodes and the issue still persists.
  • Entries similar to the below are visible in /var/log/search/search-inventory.log


2024-02-15T19:26:49.817Z ERROR pool-80-thread-1 UfoInitializer 85532 - [nsx@6876 comp="nsx-manager" errorCode="MP60525" level="ERROR" subcomp="cm-inventory"] [Search: Initialization] Exception while fetching metadata with id inventory org.opensearch.OpenSearchStatusException: OpenSearch exception [type=no_shard_available_action_exception, reason=No shard available for [get [inventory_metadata][_doc][inventory]: routing [null]]]

 

2024-02-15T19:56:33.970Z INFO pool-51-thread-1 UfoReIndexingManager 85532 - [nsx@6876 comp="nsx-manager" level="INFO" subcomp="cm-inventory"] [Indexing: Reindexing] Waiting for search framework initialization. Initialization status: FAIL


Environment

VMware NSX-T Data Center 4.x
VMware NSX-T
VMware NSX-T Data Center

Cause

The Search Framework Initialization fails in the inventory application, as the metadata cannot be read from Search after the upgrade due to the no_shard_available_action_exception.

Resolution

This is a known issue impacting VMware NSX.

Workaround:

Execute the below commands in root on all the NSX-T Manager nodes starting with the non-VIP leader nodes first.

  1. service cm-inventory restart
  2. service phonehome-coordinator restart
  3. service idps-reporting-service restart
  4. service proton restart