General error when executing Traceflow through NSX-T Manager UI
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General error when executing Traceflow through NSX-T Manager UI

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Article ID: 312632

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Updated On:

Products

VMware NSX

Issue/Introduction

  • NSX-T 3.2.x
  • When attempting to use Traceflow on the Manager tab the user encounters "General Error"
  • In the NSX Manager support bundle, the below entries in var/log/proton/nsxapi.log are visible:
2023-02-07T13:49:19.288Z ERROR http-nio-127.0.0.1-7440-exec-4 AbstractPersistentQueue 4464 - [nsx@6876 comp="nsx-manager" errorCode="PQS300" level="ERROR" reqId="2abc828d-####-45c4-####-0e8772123a58" s2comp="abstract-persistent-queue" subcomp="manager" username="admin"] Queue lm-notification-queue is full. Number of messages in queue: 100000, Max number of messages allowed: 100000
2023-02-07T13:49:19.288Z ERROR http-nio-127.0.0.1-7440-exec-4 MpTraceflowServiceImpl 4464 MONITORING [nsx@6876 comp="nsx-manager" errorCode="MP99" level="ERROR" reqId="2abc828d-####-45c4-####-0e8772123a58" subcomp="manager" username="admin"] Exception occurred in traceflow creation
com.vmware.nsx.management.ops.traceflow.common.exceptions.TraceflowException: Error in create TraceflowModel



Environment

VMware NSX-T Data Center 3.x

Cause

Due to a change in the algorithm of Traceflow which can result in General Error in the UI.

Resolution

This issue is resolved in NSX-T 4.x, available at Download Broadcom products and software

Workaround:
Start Traceflow on the Policy tab.