[VMC on AWS] AD user accounts experiencing slow logins and folder expansion
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Article ID: 312510
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Updated On:
Products
VMware Cloud on AWS
Issue/Introduction
To provide recommended workaround for users experiencing slow logins when logging into cloud vCenter appliance and slow folder expansion
Symptoms: -When using their AD credentials,some users will experience slow logins and slow folder expansion when attempting to access Cloud vCenter. -Enable Chrome Developer tools. You'll see a "Pending" task after a user expands a vCenter folder
Cause
This particular problem impacts users who are a part of numerous AD groups. vCenter queries the LDAP server in order to get all the nested parent groups for a user. The current bug within vCenter is causing these LDAP searches to happen twice which increases the wait time. So if a user is apart of multiple AD groups this action will cause the JWT token service to timeout. The JWT token service, by default, times out after 60sec.
Resolution
Currently there is no resolution for this issue
Workaround: Use the CloudAdmin account or lower the impacted user's AD group membership.