[VMC on AWS] Direct Connect routes are being added and removed continuously from the NSX Edge route table
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Article ID: 312504
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Updated On:
Products
VMware Cloud on AWS
Issue/Introduction
The purpose of this KB is to provide a root cause and steps to remediate the problem.
Symptoms: -Users will notice intermittent network connectivity drops between the two peer sites -Users will see routes being added and removed, via the Direct Connect (Dx) Gui, within the VMC Network and Security console -Currently, this issue has been experienced by users utilizing both Direct Connect and HCX within their VMC environments.
Cause
-This issue occurs if a user is using a HCX Direct Connect Network profile that overlaps with an existing VMC on AWS network segment. If this VMC network segment is also being advertised via Direct Connect connection this can lead to a reconciliation error. This forces a continuous deletion and removal of routes from the NSX edge route table.
Resolution
This will be resolved in a future release.
Workaround: If the HCX Direct Connect segment overlaps with a VMC network segment either delete the VMC network segment or change the segments ips.
Additional Information
Impact/Risks: There is NO impact. However, before removing the VMC segment verify that no vms are attached to the segment.