HCX Network Extension appliance network connectivity lost after HA event.
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HCX Network Extension appliance network connectivity lost after HA event.

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Article ID: 312503

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Updated On:

Products

VMware Cloud on AWS

Issue/Introduction

Symptoms:
When using HCX Multi-Site Service Mesh:
  • If Network Extension appliance is power-cycled, VMs on an extended network will lose connectivity between the source and target.
  • If a host in a vSphere Availability enabled cluster experiences a host failure, and the Network Extension appliance is on the host that experienced a failure, when the Network Extension appliance is moved to a working host and powered on, VMs on an extended network will lose connectivity between the source and target.


Cause

This issue occurs due to a configuration in Network Extension that causes the target Network Extension appliance’s network adapters to have the “Connect At Power On” option disabled. This issue occurs when the following conditions are met:
  • The target environment has NSX-T.
  • HCX Multi-Site Service Mesh is deployed.
  • A network is extended.

Resolution

This is a known issue affecting HCX versions prior to release R121.

To avoid this issue, the environment’s source and target HCX Managers should be upgraded to R121, and all Network Extension appliances should be upgraded to R121.

Workaround:
Preventative Workaround:
If the environment has not yet been upgraded to R121, the issue can be prevented by taking one of the following actions:

Option 1:
Redeploy all Network Extension appliances by following these steps:
  1. In the source vSphere HCX UI, navigate to Interconnect -> Multi-Site Service Mesh -> Service Mesh
  2. Click the “View Appliances” button
  3. Check the checkbox next to the Network Extension appliances
  4. Click the “Redeploy” button

    Note: Redeploying the Network Extension appliance will cause a brief loss of connectivity on the extended network data-path between the source and target VMs while the redeploy is underway.
Option 2:
Enable the option “Connect At Power On” for all in-use network adapters of all Network Extension appliances in the target environment by following these steps:
  1. In the target vSphere UI, for each Network Extension appliance, right click on the Network Extension appliance VM and click “Edit Settings”
  2. Expand all of the network adapters that are attached to an extended network
  3. If the option “Connect At Power On” is unchecked, check the checkbox
  4. Click OK

Note: The corrective action taken in either Option 1 or Option 2 will need to be done any time a network is extended until the environment is upgraded to release R121

Impacted Workaround:
If the environment has not yet been upgraded to R121, and a vSphere Availability event has
occurred due to a host failure, or if the Network Extension appliance has been power-cycled, and
there is a loss of connectivity on the extended network data-path, the issue can be resolved by
taking the following action:

Enable the option “Connected” and “Connect At Power On” for all in-use network adapters of all Network Extension appliances in the target environment by following these steps:
  1. In the target vSphere UI, for each impacted Network Extension appliance, right click on the Network Extension appliance VM and click “Edit Settings”
  2. Expand all of the network adapters that are attached to an extended network
  3. If the options “Connected” and “Connect At Power On” are unchecked, check both checkboxes
  4. Click OK