[VMC on AWS]:  Vsphere Replication timeout error
search cancel

[VMC on AWS]:  Vsphere Replication timeout error

book

Article ID: 312502

calendar_today

Updated On:

Products

VMware Cloud on AWS

Issue/Introduction

Steps taken to troubleshoot the failure



Symptoms:

Below errors seen during SRM failover:

Object 'GID-xxx' is locked by another ongoing operation in vSphere Replication Management Server.

VR synchronization failed for VRM group "VM-name" Operation timed out


Cause

This is due to an issue with slow disk consolidation

Resolution

Currently there's no resolution and is under investigation by the SRM team.
There are steps in the workaround to help remediate the issue.

 


Workaround:

Increase the vrReplication.synchronizationTimeout and vrReplication.reverseReplicationTimeout values in the vSphere Replication Advanced Settings from 7200 to 14400 seconds.
 

The steps for increasing the timeout are described here:  https://docs.vmware.com/en/Site-Recovery-Manager/8.4/com.vmware.srm.admin.doc/GUID-C151BC3A-86E7-44D9-B475-DA1D091C619E.html#GUID-C151BC3A-86E7-44D9-B475-DA1D091C619E 


Additional Information

Impact/Risks:

Raising the timeout of the vSphere Replication Advanced Settings will not impact the current replications.
It might lead to a slightly slower failover as the synchronizationTimeout and reverseReplicationTimeout are increased.