Tenant Portal displays “No Datacenters are Available” after upgrade to 9.1
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Tenant Portal displays “No Datacenters are Available” after upgrade to 9.1

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Article ID: 312325

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

Symptoms:
When accessing the tenant portal you get the error:




Environment

VMware Cloud Director for Service Provider 9.x

Cause

The issue is due to changes in enforcement of certificates in the API/Tenant Portal.

This is caused by recent changes within the code for enforcement of the certifcates for the API and Tenant Portal. The correct format for the certifcate chain is Base64.

Resolution

1. Using a browser of your choice, view the certificate for the vCloud Director URL. Then 'click' 'Copy to file...'

Chrome: Developer Tools > Security > View Certificate 



2. 'Click' Next and choose Base-64 encoded X.509 and 'click' Next. Save the certifciate as a file. 



3. Choose the Certificate Path and repeat step 2 for each certificate in the chain.

 
4. Open the files that were created when we saved the certificates as Base64 Encoded and Copy/Paste each certificate into another file. 



5. Login into the vCloud Director UI > System > Administrattion > Public Address
6. Copy the content of the file created in step 4 and paste it into the Certificate Chain  for the API  and Tenant Portal section.