vRA7.x services do not register after a restart
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vRA7.x services do not register after a restart

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Article ID: 312231

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

This article provides details about how to make services REGISTERED after restarting vRealize Appliance when the services are showing as FAILED.


Symptoms:

After restarting the vRealize Automation Appliance, you experience these symptoms:

  • In the vRealize Appliance’s VAMI page, located at https://<vRA_FQDN_or_IP>:5480 under the Services tab, many services are not REGISTERED, either showing no status or are showing as FAILED.
  • In the /var/log/vmware/vcac/catalina.out file, you see errors similar to:

    vcac: [component="cafe:identity" priority="WARN" thread="tomcat-http--16" tenant context="abmDcLPx" token="a
    bmDcLPx"] com.vmware.vcac.authentication.service.impl.AuthenticationMessageNotificationServiceImpl.loadServiceInfoAndRegisterSolutionUserForTenants:63 - No serviceInfo found for serviceInfoId [<UUID_1>] of serviceType [com.vmware.csp.component.software.service]
    org.springframework.security.authentication.BadCredentialsException: { "error": "invalid_client", "error_description": "Client is not found."

Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.


Environment

VMware vRealize Automation 7.1.x

Cause

This issue occurs when Horizon vIDM service fails to initialize after restarting vRealize Automation 7.1.x which causes a cascading failure.

Resolution

To resolve the issue:
  1. Log in to vRealize Automation’s VAMI page configuration at https://vRA_FQDN_or_IP:5480 using root credentials.
  2. Navigate to vRA Settings > SSO.
  3. Re-enter SSO credentials by adding [email protected] as the user and the associated password.
  4. Click the Save Settings button and wait for vRealize Automation to re-register to Horizon SSO.
  5. Navigate to the Services > refresh to verify that all services are again REGISTERED.
 
NOTE: This may take approximately 10 minutes for services to fully report back and you may have to log out of the vRealize Automation VAMI and log back in.


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