Attempting to upgrade vRealize Log Insight displays the error "Upgrade already in progress"
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Attempting to upgrade vRealize Log Insight displays the error "Upgrade already in progress"

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Article ID: 312214

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • Attempting to upgrade vRealize Log Insight from the UI, display get the error "Upgrade already in progress".


Cause

This issue occurs when there is a previously failed upgrade and the database has not been properly updated with failure information.

Resolution

  1. Log into the Primary node as root via SSH or Console, pressing ALT+F1 in a Console to log in.
  2. Connect to the Cassandra database by following the steps described in How to Access the Cassandra Database in vRealize Log Insight (57901).
  3. Once in Cassandra, run the following command to set the previous upgrade attempt status to failed:
update logdb.upgrade_status set status='Failed' where version='version_number';

Note:  Replace version_number with the actual version you are attempting to upgrade to.

Exampleupdate logdb.upgrade_status set status='Failed' where version='8.3.0.17501338';
  1. Run the following command to display a list of node IDs pertaining to the previous upgrade attempt:
select node_id from logdb.node_upgrade_status where version='version_number';

Note:  Replace version_number with the same version number you used in step 3.

Exampleselect node_id from logdb.node_upgrade_status where version='8.3.0.17501338';
  1. Note each node ID displayed in the node_id column.
  2. For each noted node_id run the following command to set the upgrade stats to complete:
update logdb.node_upgrade_status set status='Complete' where version='version_number' and node_id='id';

Note: Replace version_number with the same version number you used in step 3, and replace id with one of the node IDs noted in step 5.

Exampleupdate logdb.node_upgrade_status set status='Complete' where version='8.3.0.17501338' and node_id='<UUID_1>';
  1. Repeat step 6 for all node IDs noted in step 5.
  2. Exit the Cassandra database by running:
exit
  1. Retry the upgrade from the vRealize Log Insight UI.