Rotating Aria Operations for logs password breaks connectivity from Aria Operations to Aria Operations for Logs.
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Rotating Aria Operations for logs password breaks connectivity from Aria Operations to Aria Operations for Logs.

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Article ID: 312169

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Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

If the admin password of Aria Operations for Logs (AO4L) is changed from SDDC Manager, the Aria Operations (AOps) is unable to connect to AO4L. The below logs are displayed in /var/log/vmware/vcf/operationsmanager/operationsmanager.log:

2023-08-10T16:49:56.483+0000 DEBUG [vcf_om,d958bd81c32690e3,371c] [c.v.v.secure.http.HttpClientService,om-exec-23] Making request: POST https://hostname-22:9543/api/v1/sessions
2023-08-10T16:49:56.682+0000 DEBUG [vcf_om,d958bd81c32690e3,371c] [c.v.v.secure.http.HttpClientService,om-exec-23] Received response: for POST request with host: Hostname-22, port: 9543, isSecure: true, path: /api/v1/sessions, queryParamMap: null, headers: {Accept=application/json, Content-Type=application/json}
2023-08-10T16:49:56.682+0000 DEBUG [vcf_om,d958bd81c32690e3,371c] [c.v.v.secure.http.HttpClientService,om-exec-23] Response Body: {"errorMessage":"Invalid credentials or account is locked.","errorCode":"FIELD_ERROR"}

Environment

VMware Cloud foundation 5.x
VMware Cloud Foundation 5.1.1
VMware Cloud Foundation 5.1.0
VMware Cloud Foundation 5.1

Cause

After rotating the AO4L password, the new password were not synced back to AOps.

Resolution

Unlock the AO4L admin account by running the below command on the AO4L server (Refer to KB 339878):

/usr/lib/loginsight/application/sbin/li-reset-admin-passwd.sh --unlockAdmin

Next, log in to Aria operations UI and update the new Aria Operations for Logs password.

Note: This problem applies to all the VCF 5.1.x or older versions.