SMTP credentials cannot be configured via VPXD in VC 8.0 series.
book
Article ID: 312125
calendar_today
Updated On:
Products
VMware vCenter Server
Issue/Introduction
Customers should be aware of the issue in case they use this feature, and wish to set-up or modify this configuration in vCenter 8.0 GA or U1.
Symptoms: Attempting to edit any of the following OptionManager values through the Advanced Settings UI or a VMOMI client will fail if "mail.smtp.username" is non-empty. mail.smtp.server mail.smtp.password mail.smtp.username mail.smtp.port
Environment
VMware vCenter Server 8.0.1 VMware vCenter Server 8.0.x VMware vCenter Server 8.0.2
Cause
In an effort to increase the security of the VC Appliance, VPXD was inadvertently made unable to modify a configuration file required to set the SMTP credentials. So, when the username field is populated, VC will fail any attempts to edit the configuration values, and they will remain unset or fixed at the previous configuration.
Resolution
The issue has been fixed internally, with VPXD regaining the ability to modify the credentials. This fix will be present in the next vCenter release.
Workaround: Initial setup:
In the Advanced Settings UI or OptionManager API, set "mail.smtp.username" to an empty string if it isn't already. This MUST be done first.
Set "mail.smtp.password" to an empty string as well.
Next set "mail.smtp.server" and "mail.smtp.port" to the desired values.
If using the vSphere UI, "mail.smtp.server" is found under General Settings with the name "Mail server", instead of under Advanced Settings.
Each time the username/password needs changing:
On the VC appliance as root, edit "/etc/mail/auth/auth-info" to contain the desired username, password, and server.
As root, run "/usr/lib/vmware-vpx/config_sendmail.sh -s <server> -p <port> -a login,plain", while adjusting the server and port in that command as needed.
Performing this workaround will not affect the appliance's ability to receive the official fix.