Re-configuring SMTP credentials from vCenter Server UI is not available.
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Re-configuring SMTP credentials from vCenter Server UI is not available.

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Article ID: 312125

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Attempting to edit any of the following OptionManager values through the Advanced Settings UI or a VMOMI client will fail if "mail.smtp.username" is non-empty.

As a result, below settings cannot be modified:
  • mail.smtp.server
  • mail.smtp.password
  • mail.smtp.username
  • mail.smtp.port

Environment

VMware vCenter Server 8.0.1

Cause

In an effort to increase the security of the VC Appliance, VPXD was inadvertently made unable to modify a configuration file required to set the SMTP credentials. So, when the username field is populated, VC will fail any attempts to edit the configuration values, and they will remain unset or fixed at the previous configuration.

Resolution

This issue is fixed in VMware vCenter Server 8.0 Update 2 Build 22385739

As a workaround, perform the below steps.

  1. In the Advanced Settings UI or OptionManager API, set "mail.smtp.username" to an empty string if it isn't already. This MUST be done first.
  2. Set "mail.smtp.password" to an empty string as well.
  3. Next set "mail.smtp.server" and "mail.smtp.port" to the desired values.
  4. If using the vSphere UI, "mail.smtp.server" is found under General Settings with the name "Mail server", instead of under Advanced Settings.
In case the username/password needs to be updated, refer following steps.
  • On the VC appliance as root, edit "/etc/mail/auth/auth-info" to contain the desired username, password, and server.
  • As root, run "/usr/lib/vmware-vpx/config_sendmail.sh -s <server> -p <port> -a login,plain", while adjusting the server and port in that command as needed.