Netdump FAILED couldn't attach to dump server on ESXi 7.0.x.
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Article ID: 312008
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Updated On:
Products
VMware vSphere ESXi
Issue/Introduction
There are many reasons for this phenomenon. ThisĀ article describes that due to configuration problems, that is, the vmknic used by netdump has more than one NIC teaming active Uplink device, which may cause this problem. Users will encounter failure in the case of a specific network and configuration.
Symptoms: During PSOD dump netdump phase, there are error messages in PSOD screen. Starting network netdump from 10.1.1.1 to 10.1.1.2 Netdump: FAILED: Couldn't attach to dump server at IP 10.1.1.2. Stopping Netdump.
Environment
VMware vSphere ESXi 7.0.x
Cause
The reason is, netdump preferentially uses the active Uplink device during configuration, but when netdump occurs, the active Uplink device in the actual teaming may have changed, so for external switches, this is a MAC drift, which may cause ESXi netdump to not receive a response packet within the expected time.
Resolution
Currently there is no resolution.
Workaround: The ESXi netdump process basically does not use multiple Uplink devices, do not configure multiple active Uplink devices for the vmknic used by netdump.