Resolve errors of interop prechecks during vcsa upgrades.
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Resolve errors of interop prechecks during vcsa upgrades.

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Article ID: 311872

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

During vCenter Server upgrade operations, you see certain interoperability precheck errors in the vcsa-ui-installers or vcsa-cli-installers related to activating the VMware's Customer Experience Improvement Program (CEIP) and network connectivity on the source vCenter Server appliance.
Interoperability precheck errors are as follows:
 
SL

Error Message

Cause

Remediation

1.Unable to check products interoperability.This error appears if an internal error has occurred and the installer has failed to check interoperability.

 
Follow the steps in the Solution section below.
2.The cloud analytics service is inaccessible.This error appears if the cloud analytics service is unreachable, for example, the source vCenter Server appliance is offline, or the service is having some issues.Examine the logs of the analytics service logs at /var/log/vmware/analytics/analytics.log for further troubleshooting. Follow the steps in the Solution section below.
3.Products interoperability checks work only if the vCenter Server appliance is joined to the VMware's Customer Experience Improvement Program.Interoperability checks requires CEIP enablement on the source vCenter Server appliance.Enable CEIP on the source appliance to enable interoperability checks on the source appliance or perform the steps in the Solution section below.
4.The target vCenter Server version must be compatible with the other products in the deployment.This error appears when interoperability data for the target vCenter Server version is not published yet.Open a support request to get interoperability data and perform Step 2 in the Solution section below.
5.Found incompatible products with target vCenter Server appliance. The list of incompatible products and there corresponding versions also appear in the error message.To continue the upgrade, you can use a skip flag as suggested in the Solution section below.
6.Products interoperability could not be fully checked. This error appears if the product name or version is not recognized by the cloud analytics service.Open a support request to get interoperability data and perform Step 2 in the Solution section below.


Resolution

To resolve the interoperability pre-check errors, follow these steps:

  1. Manually check products interoperability at https://interopmatrix.vmware.com/Interoperability.

  2. Run the CLI installer with the skip-product-interop-check argument to skip the prechecks. Use this argument after checking the interoperability of the VMware products in the deployment with the target vCenter Server version.
    Example:
    Precheck-only command: vcsa-deploy upgrade path_to_the_json_file list_of_arguments --precheck-only --skip-product-interop-check
    Upgrade command: vcsa-deploy upgrade path_to_the_json_file list_of_arguments --skip-product-interop-check

    NOTE: For Error 5 above, if you use the skip-product-interop-check argument, the upgrades will result in a broken link with incompatible products.
    If vCenter Server is a part of a VMware Cloud Foundation deployment, perform upgrades by using SDDC Manager only.