Received error code 500139 when creating T0 gateway from Global Manager
search cancel

Received error code 500139 when creating T0 gateway from Global Manager

book

Article ID: 311857

calendar_today

Updated On:

Products

VMware NSX Networking

Issue/Introduction

Symptoms:
You are using Federation and recently changed certificates on the NSX-T Local Managers. 

After replacing the Local Manager (LM) certificate in a Federated deployment. You received the following error message from the Global Manager (GM) UI when creating T0 gateway

Error: Unable to fetch TransportZoneListResultDto List from NSX, enforcement point default. (Error code: 500139)

Environment

VMware NSX-T Data Center 4.x
VMware NSX-T Data Center
VMware NSX-T Data Center 3.x

Cause

This issue occurs due to how the federation Global manager imports new certificates for the local manager and leaves the old thumbprint in place on the Global manager, which causes communications issues between the Global managers and the Local managers.

Resolution

This is a known issue impacting NSX-T.

Workaround:
  1. Browser to the LM site, find the SHA-256 Thumbprint.
    • In Chrome, other browsers may be different, this can be down by clicking the lock symbol in the address bar.
    • Selecting Connection is Secure and then clicking Certificate is Valid, you will be present with the certificate Thumbprints of the LM.
  2. It should look like:
    • 56 32 91 96 66 68 B9 C7 9F 05 40 A0 DA 0C E4 B3 AB 6C 23 8D 3E 1F A3 78 08 4A B7 CD 4D C7 B4 64 
  3. Replace all spaces with nothing, so it becomes:
    • 563291966668B9C79F0540A0DA0CE4B3AB6C238D3E1FA378084AB7CD4DC7B464
  4. Login to the GM and go to 'System->Location Manager'.
  5. Select 'Actions->Edit Settings' for relevant LM site, where we just got the Thumbprint for.
  6. Add the Thumbprint, without spaces, to SHA-256 Thumbprint field and the required password.
  7. Then click 'Check Version Compatibility' button in same box.
  8. Then click the 'Save' button.

You can also identify the LM SHA-256 Thumbprint from the NSX UI
  1. Login to the on boarded Manager
  2. Navigate to system -> Appliances
  3. Under Show Details, you can click thumbprint