NSX UI resulting error as "General error has occurred (Error code: 100)" while checking DFW statistics
search cancel

NSX UI resulting error as "General error has occurred (Error code: 100)" while checking DFW statistics

book

Article ID: 311842

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

DFW statistics do not display correctly in NSX Federation deployments, and the NSX Manager UI shows the following error messages:
General error has occurred (Error code: 100)

NSX manager syslog shows credential were incorrect:

YYYY-MM-DD HH:MM:SS.ms  NSX-Manager NSX 6025 POLICY [nsx@6876 comp="global-manager" errorCode="MP500018" level="ERROR" subcomp="global-manager"] Error in running REST api GET https://nsxmanager/api/v1/uc-state:The credentials were incorrect or the account specified has been locked.
YYYY-MM-DD HH:MM:SS.ms NSX-Manager NSX 6025 - [nsx@6876 comp="global-manager" level="WARNING" subcomp="global-manager"] Error error_code=100, module_name=common-services, error_message='General error has occurred.

Environment

VMware NSX

Cause

This issue is typically caused by the expiration of the admin credentials utilized for Location Manager connectivity.

Resolution

  1. Verify the administrative account utilized for Location Manager authentication to ensure the password has not expired.
  2. Refer the "resetting-expired-passwords" documentation to update the local user credential if an expiration has occurred.
  3. Access the Global Manager UI and navigate to System > Location Manager.
  4. Locate the target location under the Locations section and select Actions > Edit settings.
  5. Update the administrative password in the Location Manager section for all applicable locations.