The vmware-hostd process fails and restarts unexpectedly on the ESXi host
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The vmware-hostd process fails and restarts unexpectedly on the ESXi host

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Article ID: 311222

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction


Symptoms:
  • The ESXi host is not responding in vCenter Server.
  • The vmware-hostd process fails and restarts unexpectedly.
  • In the vobd.log file (on the ESXi host), located at /var/log/, you can see an entry similar to,:

    yyyy-mm-ddThh:mm:ss.nnnZ: [UserWorldCorrelator] nnnnnus: [esx.problem.hostd.core.dumped] /bin/hostd crashed (n time(s) so far) and a core file may have been created at /var/core/hostd-worker-zdump.nnn. This may have caused connections to the host to be dropped.

  • In the vmware-hostd process, you can see a coredump file named as hostd-zdump.NNN or hostd-worker-zdump.NNN is located at /var/core/ on the ESXi host.
  • Immediately preceding the vmware-hostd process failure and restart, the hostd.log file on the ESXi host contains error message similar to:

    [nnnnnnn info 'Default'] CreateISCSIHBA



Environment

VMware vSphere ESXi 5.5
VMware ESXi 4.1.x Installable
VMware ESXi 4.0.x Embedded
VMware vSphere ESXi 5.1
VMware ESXi 4.0.x Installable
VMware vSphere ESXi 5.0
VMware ESXi 4.1.x Embedded

Cause

This outage is caused by an iSCSI Management API (IMA) plug-in installed and running inside the vmware-hostd process. IMA plug-ins ship with iSCSI drivers and are part of the same installable VIB. The corresponding iSCSI HBA hardware is not required to be present to trigger the outage.

Resolution

Note: This article describes a specific set of issues. If you experience some, but not all of the symptoms as described under the Symptoms section, this article is not applicable.

This is a known issue affecting ESXi hosts with iSCSI drivers installed.
To resolve this issue, remove or upgrade iSCSI drivers on the ESXi hosts. These driver versions have known compatibility issues:
Note: If no known issue is applicable, file a support request with VMware Support and note this Knowledge Base article ID (2083154) in the problem description. For more information, see Filing a Support Request in Customer Connect (2006985).


Additional Information

How to file a Support Request in Customer Connect
Hostd becomes unresponsive after enabling driver for software ISCSI when installed from the ESXi 5.5 Update 1 Driver Rollup ISO
ESXi ホスト上で vmware-hostd プロセスが予期せずに停止したり再起動される