Cannot access VMware vCenter Server Appliance after upgrading from vCenter Server Appliance 5.0/5.1 to 5.5
search cancel

Cannot access VMware vCenter Server Appliance after upgrading from vCenter Server Appliance 5.0/5.1 to 5.5

book

Article ID: 311178

calendar_today

Updated On:

Products

VMware VMware Cloud Director VMware vCenter Server

Issue/Introduction

Symptoms:
After upgrading from vCenter Server Appliance (VCSA) 5.0 or 5.1 to 5.5, you experience these symptoms:
  • You are unable to log in or access the VCSA using:

    • vSphere Client
    • vSphere Web Client
    • vCenter Server Appliance Administrator page
    • SSH

  • The new VCSA 5.5 is configured on a subnet which differs from the earlier VCSA before the upgrade was performed.


Environment

VMware Cloud Director Appliance 5.5.x
VMware vCenter Server Appliance 5.1.x
VMware vCenter Server Appliance 5.0.x

Cause

This is an expected behavior and occurs if you upgrade to vCenter Server Appliance 5.5 with this existing configuration:
  • The source vCenter Server Appliance has a static IP configuration.
  • The source vCenter Server Appliance and the target vCenter Server Appliance are in different subnets.

Resolution

To restore networking for the vCenter Server Appliance, configure the Default Gateway to the proper gateway of your network and change the IP address:
  1. Using the vSphere Client, log in to the ESXi host running the vCenter Server Appliance.
  2. Open a virtual machine console to the vCenter Server Appliance.
  3. Press Enter to access the shell prompt.
  4. Log in with the root account credentials.
  5. Run this command to access the VAMI to configure networking for the appliance:

    /opt/vmware/share/vami/vami_config_net

  6. In the VAMI, press 2 and configure the Default Gateway to the proper gateway of your network.
  7. Press 6 and change the IP address to one that works on the network.
  8. Press 1 to exit the VAMI.
  9. Run the exit command to exit the shell session.
  10. Review the vCenter Server Appliance console and ensure that the IP address has changed in the To manage your appliance line.