How to fix the error "MDBTools_0309E - DBDriver failed to install" that occurs while running the setupmdb command for installing a MDB Patch?
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Article ID: 31110
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Updated On:
Products
SUPPORT AUTOMATION- SERVERCA Service Desk Manager - Unified Self ServiceCA Service Desk ManagerCA Service Management - Asset Portfolio ManagementCA Service Management - Service Desk Manager
Issue/Introduction
From install.log:
"MDBTools_0309E - DBDriver failed to install" that occurs while running the setupmdb command for installing a MDB Patch.
SETUPMDB log shows:
ERROR - com.microsoft.sqlserver.jdbc.SQLServerException: The index 'evt_x0' is dependent on column 'sym'.
Environment
CA Service Desk 17.X
Cause
This problem occurs due to the index 'evt_x0' being present on the 'evt' table in the MDB.
Resolution
Login to SQL Management Studio as a SQL administrator;
Expand MDB Database;
Expand the table dbo.evt -> Expand Indexes -> Right-click on evt_x0 -> Select Script table as -> Create to -> Copy the complete CREATE INDEX into a text editor;
Right-click on the 'evt_x0' index and delete;
Run SETUPMDB to install the MDB patch.
Upon successful completion of SETUPMDB, go back to the SQL Query Window and paste the copied 'evt_x0' index saved in step #1 above and execute the query to recreate the 'evt_x0' index..