Hook timeout error when accessing virtual machine console through vSphere Client
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Hook timeout error when accessing virtual machine console through vSphere Client

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Article ID: 311007

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Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • When connected to an ESXi/ESX host or vCenter Server you are unable to access the virtual machine console using a VMware Infrastructure/vSphere Client.
  • You see errors similar to:

    Cannot read keyboard, hook timeout
    Cannot read keyboard hook timeout value from the registry: More data is available

  • When directly connected to the ESXi/ESX host you see a black screen when accessing the console.


Environment

VMware vCenter Server 4.0.x
VMware VirtualCenter 2.5.x
VMware ESX 4.0.x
VMware vCenter Server 5.0.x
VMware ESXi 3.5.x Installable
VMware ESXi 4.1.x Embedded
VMware ESXi 4.0.x Embedded
VMware ESXi 4.0.x Installable
VMware ESX Server 3.5.x
VMware ESXi 4.1.x Installable
VMware vSphere ESXi 5.0
VMware ESX 4.1.x
VMware vCenter Server 4.1.x
VMware ESXi 3.5.x Embedded

Cause

This issue occurs when LowLevelHooksTimeout ends services automatically when they are not responding.

Resolution

To resolve this issue, ensure the registry key LowLevelHooksTimeout exists and has the recommended value of 5000 in the workstation where the vSphere Client is installed.
To check if the registry key exists and has the recommended value, run the command:

\HKEY_CURRENT_USER\Control Panel\Desktop\LowLevelHooksTimeout 5000 (DWORD and decimal value)
If the key does not exist, create it and set it to the recommended value of 5000. If the value is different, change it to the default value.
To set up the registry key:
  1. Click Start > Run, type regedit and click OK.
  2. Navigate to \HKEY_CURRENT_USER\Control Panel\Desktop\.
  3. Right-click LowLevelHooksTimeout > Modify located in the right pane.
  4. Select Decimal and enter the default value of 5000.