Adding an ESXi host to the vCenter Server inventory fails with the error: Call "datacenter.queryconnectioninfo" for object on vCenter Server failed
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Adding an ESXi host to the vCenter Server inventory fails with the error: Call "datacenter.queryconnectioninfo" for object on vCenter Server failed

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Article ID: 310991

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Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

  • Cannot add an ESXi host to the vCenter Server inventory.
  • Adding an ESXi host to the vCenter Server inventory fails.
  • You see the error:

Call "datacenter.queryconnectioninfo" for object "DC or Cluster Name" on vCenter Server "vCenter" failed.

  • In the vCenter service log, /var/log/vmware/vpxd, entries can be found which:
    • Indicate that connections to the ESXi host are refused.
    • Advise you to check that the vmkauthd service is running on the ESXi host

Environment

  • VMware vCenter Server 6.x
  • VMware vCenter Server 7.0.x
  • VMware vSphere ESXi 6.x
  • VMware vSphere ESXi 7.0.x

Cause

This issue occurs when there is an issue with network communication between the vCenter Server and the ESXi host that is added to the inventory.

Resolution

To resolve this issue, verify these steps from the vCenter Server machine:
  • Ensure that the version of vCenter Server is same or higher than the ESXi host being added.
  • Confirm that the ESXi version is compatible with the vCenter Server versio, using the VMware Product Interoperability Matix
  • When using the IP address of the ESXi host, verify that this IP address is the one configured for the management vmkernel interface.
  • Verify you are able to connect to the ESXi host using the ESXi host client.
  • Verify the DNS records for the ESXi host is configured correctly.
  • Verify the ESXi host ports are accessible. For more information, see Troubleshooting network and TCP/UDP port connectivity issues on ESX/ESXi.
  • Should you see the following message after closing the datacenter.queryconnectioninfo error prompt:
    Cannot contact the specified host. The host may not be available on the network, a network configuration problem may exist, or the management service on this host is not responding

    Increase the SSL handshake timeout to 12000. For more information, see Alarms about the host connection state changing from green to red frequently occur.
     
This also occurs when:


Additional Information