The file uploads successfully but no further progress is observed.
You are running any version up to NSX-V 6.4.4
Environment
VMware NSX for vSphere 6.4.x
Cause
Database restore takes longer than 3 minutes (180,000 seconds) which causes a timeout and prevents the upgrading progressing.
Two specific timeout limits can cause timeout when restoring large sized database.
You see a similar log entry to the below in the vsm logs: INFO localhost-startStop-1 DatabaseMetadata:119 - table not found: access_control_entry
Resolution
There is currently no resolution.
Workaround: Adjust the timeout value to allow sufficient time for the database to restore.
1) Edit the file /usr/appmgmt-tcserver/webapps/ROOT/appliance-management/js/services/DataService.js in appliance. 2) Search for the line "var HTTP_DEFAULT_TIMEOUT = 180000;" 3) Change the time out value from 180000 ms (3 minutes) to 1200000 ms (20min). 3) reboot the appliance or restart bluelane-manager.