The vCenter Server Service status, Licensing Reporting Manager, and vCenter Hardware Status plug-ins fail with the error: The remote server returned an error: (404) Not Found
search cancel

The vCenter Server Service status, Licensing Reporting Manager, and vCenter Hardware Status plug-ins fail with the error: The remote server returned an error: (404) Not Found

book

Article ID: 310507

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

This article provides steps to change VMware VirtualCenter Management Webservices (Tomcat) – HTTPS port when its default port 8443 is already used by a third party application.

Symptoms:
  • In the Performance Overview tab, you see this error:

    Navigation to the webpage was cancelled. Refresh the page

  • The vCenter Server Service Status, Licensing Reporting Manager, and vCenter Hardware Status plug-ins fail
  • You see these errors:

    • The following error occurred while downloading the script plugin from
      https://vCenter:8443/health-ui/scriptConfig.xml : The remote server returned an error: (404) Not Found.
    • The following error occurred while downloading the script plugin from
      https://vCenter:8443/cim-ui/scriptConfig.xml : The remote server returned an error: (404) Not Found.
    • The following error occurred while downloading the script plugin from
      https://vCenter:8443/license-ui/scriptConfig.xml : The remote server returned an error: (404) Not Found.

  • VMware Management Web Services service starts without issues, but listens only on port 8005 and 8080


Environment

VMware vCenter Server 5.0.x
VMware vCenter Server 4.1.x
VMware vCenter Server 5.1.x
VMware vCenter Server 4.0.x
VMware vCenter Server 5.5.x

Cause

This issue may occur when port 8443 (default port of Management Web Services – HTTPS) is already used by another program.

Note: This issue may also occur in vCenter Server 5.1/5.5 when port 8003 is in use by another program. For more information, see TCP and UDP Ports required to access VMware vCenter Server, VMware ESXi and ESX hosts, and other network components (1012382).

Resolution

Verify that the VMware VirtualCenter Management Webservices is only listening on port 8005 and 8080 and identify which process or program is using port 8443:

    • On vCenter Server, launch Command Prompt
    • Type netstat -ano
    • Note the PID of port 8005 and port 8080. The PIDs should be the same.
    • Note the PID of port 8443. This is the PID of the process that is using port 8443.
    • On vCenter Server, launch Task Manager.
    • On Task Manager, select Processes tab
    • Select View from the menu bar and then Select Columns option
    • Check PID (Process Identifier) and click OK
    • Find the match PID in the Task Manager's Process List
    • PID we noted at step c should be Tomcat6.exe as process name
    • PID we noted at step d should be the process that is listening on port 8443

    Note: This issue may also occur in vCenter Server 5.1/5.5 when port 8003 is in use by another program. If you continue to experience issues, repeat the steps above, substituting port 8443 with port 8003.

    • After the process name is found at step k, check if that process or program can be uninstalled or if its port can be changed to a different port number.

      • %ProgramFiles%\VMware\Infrastructure\VirtualCenter Server\extensions\cim-ui\extension.xml
      • %ProgramFiles%\VMware\Infrastructure\VirtualCenter Server\extensions\license-ui\extension.xml
      • %ProgramFiles%\VMware\Infrastructure\VirtualCenter Server\extensions\com.vmware.vim.stats.report\extension.xml
      • %ProgramFiles%\VMware\Infrastructure\tomcat\webapps\health-ui\scriptConfig.xml
      • %ProgramFiles%\VMware\Infrastructure\tomcat\webapps\cim-ui\scriptConfig.xml
      • %ProgramFiles%\VMware\Infrastructure\tomcat\webapps\license-ui\scriptConfig.xml

    • Locate port number 8443 in each of above files and change it to the new port.
    • Restart the VMware VirtualCenter Management Webservice. For instructions on restarting the these services, see Stopping, starting, or restarting the vCenter Server service (1003895).


    Additional Information


    Performance Overview, Hardware Status, vCenter Server Status and Storage View Plug-ins do not appear if the vCenter Server host is renamed
    TCP and UDP Ports required to access VMware vCenter Server, VMware ESXi and ESX hosts, and other network components
    vCenter Server Service Status plug-in cannot be enabled
    Required ports for vCenter Server 5.0
    vCenter Server サービス ステータス、Licensing Reporting Manager、および vCenter ハードウェア ステータスの各プラグインが次のエラーで失敗する:リモート サーバがエラーを返しました: (404) 見つかりません