Error "IO Error: The Network Adapter could not establish the connection" occurs when configuring CA Service Desk Manager (SDM).
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Error "IO Error: The Network Adapter could not establish the connection" occurs when configuring CA Service Desk Manager (SDM).

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Article ID: 31047

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Updated On:

Products

CA Service Management - Service Desk Manager ServiceDesk CA Service Desk Manager

Issue/Introduction

The following error message occurs when running CA Service Desk Manager (CA SDM) configuration (pdm_configure) with Oracle as the MDB database:

java.sql.SQLException: IO Error: The Network Adapter could not establish the connection

Environment

Release:  17.1 or higher
Component: CA Service Desk Manager

Cause


"java.sql.SQLException: IO Error: The Network Adapter could not establish the connection" - This error message is Oracle's way of saying either 'Connection refused' or 'Connection timeout' or 'no route to host' or 'unknown host'. 

This is a very generic error that could occur due to various reasons. Below are the points that need to be checked to fix this problem:

  • Wrong port number or IP address (or DNS host name) is used.
  • Oracle listener is not configured properly or not available.
  • Listener process (service) is not running. Restart it with the "lsnrctl start" command or on a Windows OS by starting the listener service. 
  • Ensure the correct hostname is specified in listner.ora.
  • Add the hostname and IP address in the hosts file located under C:\Windows\System32\drivers\etc folder.
  • This could be a problem with the Oracle SYS user password. Check with the Oracle DBA for the correct credentials.

Resolution

Work with your Network team to resolve the Oracle issue.

Additional Information