Spectrum OneClick Alarm: Error: LDAP login failed for user <user_name>
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Spectrum OneClick Alarm: Error: LDAP login failed for user <user_name>

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Article ID: 31007

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Updated On:

Products

CA Spectrum

Issue/Introduction

An explanation around LDAP login errors and how to prevent them. 

Environment

Release:
Component: SPCAEM

Cause

Could be an incorrect password configured or no user in the LDAP system.

Resolution

When LDAP is enabled, OneClick will always try to authenticate with LDAP first for all users. When this occurs for a user that is not in LDAP, the following error occurs: 

Error: LDAP login failed for user <user_name>


After this OneClick checks to see if this is a Super User or if this is a user configured to be allowed to log into OneClick if no LDAP user is found. If so, then OneClick will authenticate from the Spectrum database.

Events are logged for these LDAP login successes and failures. If three failures in a row are detected than the 0x000cb003 is generated and the alarm is asserted. The event is a failure to authenticate through LDAP not a failure to log into OneClick. 

To debug the issue, you can turn on the SSORB Security SP debug and review the tomcat log file for info - 
In the OneClick Administration page, click Administration - Debugging - Web Server Debug (Runtime) SSORB Security SP - set to On, scroll to the bottom, Select Apply.  Reproduce the issue.


If you do not wish to see this alarm for a particular user, the user can be added to LDAP. If you do not wish to see this alarm at all, the 0x000cb003 can be edited to remove the alarm.

Additional Information

  • If you have other Broadcom/CA products installed, it may be that the username/password in the other Broadcom/CA product needs to be reset.  
  • You can view the Client Log on the OneClick Administration Page to determine where the failed login attempt is originating from: