vSphere Web Client 中出现“没有可用的 NSX Manager (No NSX Managers available)”错误
search cancel

vSphere Web Client 中出现“没有可用的 NSX Manager (No NSX Managers available)”错误

book

Article ID: 309992

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

Symptoms:

免责声明:本文为 No NSX Managers available" error in the vSphere Web Client 的翻译版本。尽管我们会不断努力为本文提供最佳翻译版本,但本地化的内容可能会过时。有关最新内容,请参见英文版本。

使用 vSphere Web Client 连接至 vCenter Server 并导航至主页>网络和安全时,您遇到以下症状:
  • 没有可用的 NSX Manager。
  • 在“网络和安全清单”下,报告的 NSX Manager 数量为 0。
  • 选择“NSX 主页”时,您会看到以下错误:

    没有可用的 NSX Manager。请确认当前用户具有在 NSX Manager 上分配的角色
    (No NSX Managers available. Verify current user has role assigned on NSX Manager)。
  • 在 NSX Manager 中取消注册和重新注册 Lookup Service 失败。
  • 您会看到以下错误:

    NSX 管理服务操作失败。管理注册服务提供程序初始化失败。根本原因: NSX Manager 与 Lookup Service 的时钟不同步,他们需要同步。请检查 NTP 配置
    (NSX Management Service operation failed. Initialization of Admin Registration Service Provider failed. Root Cause: NSX Manager and Lookup service clocks are not in sync. They need to be synchronized. Please check NTP configuration)。

Environment

VMware NSX for vSphere 6.2.x
VMware NSX for vSphere 6.3.x
VMware NSX for vSphere 6.0.x
VMware NSX for vSphere 6.1.x
VMware NSX for vSphere 6.4.x

Cause

当为登录帐户配置的vCenter Server 和权限不正确时出现此问题。

Resolution

要解决此问题,请正确配置该帐户的权限。
 
要正确配置该帐户的权限,请执行以下操作:
  1. 使用 Web UI 登录到 NSX Manager。
  2. 单击管理 vCenter 注册
  3. 导航到组件>NSX 管理服务
  4. 确保 vCenter Server 配置正确。
同时确保正确配置登录帐户的权限。有关用户权限的详细信息,请参见 NSX for vSphere Administration Guide 中的“用户管理”部分。
 
注意
  • 验证用户帐户 [email protected] 是否发生同样的问题。如果 NSX Manager 出现在此帐户中,确保遇到问题的帐户正确配置了权限。
  • 确认 NSX Manager 与 Lookup Service 时钟同步。有关详细信息,请参见 Configuring the SSO Lookup Service fails (343361)
  • 即使 vCenter Server 和 Lookup Service 在 NSX 用户界面 (UI) 中显示已连接,但注销并使用 [email protected] 帐户重新登录后仍会显示“No NSX Managers available",可能需要终止现有 VC 会话。

    您可以在 vSphere Web Client 中导航到主机和群集,执行此操作。选择vCenter>管理>会话> 选择所有会话(“该会话”除外)> 单击终止会话。从会话注销并重新登录。确认 NSX Manager 现在是否可见。

Additional Information