Installing/Upgrading VMware vCenter Update Manager reports this error: The vCenter Server entered is not reachable
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Installing/Upgrading VMware vCenter Update Manager reports this error: The vCenter Server entered is not reachable

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Article ID: 309976

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Updated On:

Products

VMware vCenter Server

Issue/Introduction


Symptoms:
  • Cannot install VMware vCenter Update Manager
  • Cannot upgrade VMware vCenter Update Manager
  • You see the error:

    The vCenter Server entered is not reachable

  • In the vminst.log file located at %TEMP%, you see entries similar to:

    VMware Update Manager-build-1888318: <MM-DD-YY><time> VC validation command: ["-v 127.0.0.1 -p 80 -U "user" -P *********** -C "</time>
    C:\Users\profile\AppData\Local\Temp\2\vum\\" -L "C:\Users\profile\AppData\Local\Temp\2\\" -O vcversion"]
    VMware Update Manager-build-1888318: <MM-DD-YY><time> AppendPath::done Path: C:\Users\profile\AppData\Local\Temp\2\vum\vciInstallUtils.exe
    VMware Update Manager-build-1888318: <MM-DD-YY><time> Found C:\Users\profile\AppData\Local\Temp\2\vum\vciInstallUtils.exe"
    VMware Update Manager-build-1888318: <MM-DD-YY><time> Process returned 1
    VMware Update Manager-build-1888318: <MM-DD-YY><time> Error:: vciInstallUtils.exe invalid or no command line options
    VMware Update Manager-build-1888318: <MM-DD-YY><time> Getting Property UILevel = 5
    VMware Update Manager-build-1888318: <MM-DD-YY><time> Getting Property ProductName = VMware vSphere Update Manager
    VMware Update Manager-build-1888318: <MM-DD-YY><time> Setting property VCServerInfoOK =
    VMware Update Manager-build-1888318: <MM-DD-YY><time> Setting property VC_SERVER_IP_LOCAL =
    VMware Update Manager-build-1888318: <MM-DD-YY><time> ---------- End Logging---------- </time></time></time></time></time></time></time></time></time>

  • In the vmware-vci-vciinstallutils-log4cpp.log file located at %TEMP%, you see entries similar to:

    <YYYY-MM-DD><time> '' 11012 ALERT] [logUtil, 265] Product = VMware Update Manager, Version = 5.5.0, Build = 1888318
    <YYYY-MM-DD><time> '' 11012 INFO] [main, 350] Successfully configured logger
    <YYYY-MM-DD><time> '' 11012 INFO] [main, 369] command line arguments: argv 0 = C:\Users\profile\AppData\Local\Temp\2\vum\vciInstallUtils.exe argv 1 = -v argv 2 = 127.0.0.1 argv 3 = -p argv 4 = 80 argv 5 = -U argv 6 =Administrator argv 7 = -P argv 8 = xxxx(user password) argv 9 = -C argv 10 = C:\Users\profile\AppData\Local\Temp\2\vum\ argv 11 = -L argv 12 =C:\Users\profile\AppData\Local\Temp\2\ argv 13 = -O argv 14 = vcversion
    <YYYY-MM-DD><time> '' 11012 ERROR] [main, 183] cannot get registry InstallPath, exception = Error open registry key (SOFTWARE\VMware, Inc.\VMware Update Manager), ret=2, err=0
    <YYYY-MM-DD><time> '' 11012 WARN] [main, 375] cannot get install directory from user input and registry
    <YYYY-MM-DD><time> '' 11012 DEBUG] [installerRunVCCommand, 98] [VCSERVER] op name = vcversion
    <YYYY-MM-DD><time> '' 11012 DEBUG] [installerRunVCCommand, 125] [VCSERVER] logging into vc.
    <YYYY-MM-DD><time> '' 11012 DEBUG] [installerRunVCCommand, 129] [VCSERVER] host = 127.0.0.1, port = 80, user = Administrator


    </time></time></time></time></time></time></time></time>
  • In the vpxd.log file located at C:\ProgramData\VMware\VMware VirtualCenter\Logs\, you see entries similar to:

    error:140000DB:SSL routines:SSL routines:short read) on stream (null) <YYYY-MM-DD><time></time> [07896 error 'SSL SoapAdapter.HTTPService'] stream is NULL - no read scheduled
    <YYYY-MM-DD><time></time> [08052 error 'SSL SoapAdapter.HTTPService'] accept failure class Vmacore::Ssl::SSLException(SSL Exception: error:140000DB:SSL routines:SSL routines:short read) on stream (null)
    <YYYY-MM-DD><time></time> [08052 error 'SSL SoapAdapter.HTTPService'] stream is NULL - no read scheduled
    <YYYY-MM-DD><time></time> [07896 error 'SSL SoapAdapter.HTTPService'] accept failure class Vmacore::Ssl::SSLException(SSL Exception: error:140000DB:SSL routines:SSL routines:short read) on stream (null)
  • vCenter Server was installed with default ports.
  • The rui.crt file located at C:\ProgramData\VMware\VMware vSphere Auto Deploy\ssl\ is 0 bytes or corrupt.


Environment

VMware vCenter Update Manager 5.0.x
VMware vCenter Update Manager 5.1.x
VMware vCenter Update Manager 5.5.x

Cause

This issue occurs because of corrupt or empty certificate file for vSphere Auto Deploy.

Resolution

To resolve this issue, stop the VMware vSphere Auto Deploy Waiter service.
To stop the VMware vSphere Auto Deploy Waiter service:
  1. Log in as an administrator to the server that is running vCenter Server.
  2. Click Start > Run, type services.msc, and click OK. The Services window opens.
  3. Stop the VMware vSphere Auto Deploy Waiter service.
  4. Run the Update Manager installation or upgrade.

    Note: The certificate for Auto Deploy will need to be replaced to restore functionality. For information on this procedure, see Configuring CA signed SSL certificates for vSphere Auto Deploy in vSphere 5.x (2073588).



Additional Information

You may experience similar issues when vCenter Server is using custom ports. For more information, see Installing VMware Update Manager fails with the error: The vCenter Server entered is not reachable (1039226).Installing vCenter Update Manager fails with the error: The vCenter Server entered is not reachable
Creating certificate requests and certificates for vCenter Server 5.1 components
Creating certificate requests and certificates for vCenter Server 5.5 components
Configuring CA signed SSL certificates for vSphere Auto Deploy in vSphere 5.x

Impact/Risks: