Error: "The request failed because of a connection failure." connecting to vCenter Server using the vSphere Client
search cancel

Error: "The request failed because of a connection failure." connecting to vCenter Server using the vSphere Client

book

Article ID: 309856

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • Cannot connect to vCenter Server using the vSphere Client.
  • Connecting to vCenter Server using the vSphere Client fails.
  • vSphere Client fails to connect to vCenter Server.
  • You see the error:

    The request failed because of a connection failure. (Unable to connect to the remote server)
     
  • The vSphere Client logs (located at C:\Users\Administrator\AppData\Local\VMware\vpx ) contain entries similar to:

    VirtualInfrastructure.Exceptions.ConnectionError: The request failed because of a connection failure. (Unable to connect to the remote server)
    System.Net.WebException: Unable to connect to the remote server
    Server stack trace:
    at System.Net.HttpWebRequest.EndGetRequestStream(IAsyncResult asyncResult, TransportContext& context)
    Exception rethrown at [0]:
    ...
    at System.Net.HttpWebRequest.EndGetRequestStream(IAsyncResult asyncResult)
    at VirtualInfrastructure.Soap.SoapWebRequest.OnGetRequestStream(IAsyncResult result)
    System.Net.Sockets.SocketException: An invalid argument was supplied

Environment

  • VMware vCenter Server 4.0.x
  • VMware vCenter Server 5.0.x
  • VMware vCenter Server 5.1.x
  • VMware vCenter Server 4.1.x

Cause

This issue occurs if there is a proxy server between the vSphere Client and vCenter Server. The vSphere Client does not support proxy connections to connect to vCenter Server.

Resolution

Disable the connection to the proxy server using the below steps:
  1. Click Start > Control Panel.
  2. Click Network and Sharing Center or Network and Internet.
  3. Click Internet Options in the left pane.
  4. Click the Connections tab.
  5. Click LAN Settings.
  6. Deselect Use a proxy server for your LAN.
  7. Click OK.
  8. Click OK to close the Internet Properties window.