The "C:\Program Files\VMware\Infrastructure\VirtualCenter Server\vpxd -s" command also returns output similar to the above.
The vpxd.log contains entries similar to:
2012-10-30T10:00:13.210+01:00 [03604 error 'Default'] [VpxdVdb::SetDBType]: Login failure - retrying once... 2012-10-30T10:00:13.210+01:00 [03604 error 'Default'] [VpxdVdb::SetDBType] Failed to connect to database: . Retry attempt: 1 ... 2012-10-30T10:00:23.250+01:00 [03604 error 'Default'] [VpxdVdb::SetDBType] Encountered login error. Subsequent connection attempt failed: 28000 2012-10-30T10:00:23.250+01:00 [03604 error 'Default'] [VpxdVdb::SetDBType] Aborting after 1 retries. 2012-10-30T10:00:23.250+01:00 [03604 error 'Default'] Error getting configuration info from the database 2012-10-30T10:00:23.250+01:00 [03604 error 'Default'] [Vpxd::ServerApp::Init] Init failed: VpxdVdb::Init(VpxdVdb::GetVcVdbInstId(), false, false, NULL) 2012-10-30T10:00:23.250+01:00 [03604 warning 'VpxProfiler'] ServerApp::Init [TotalTime] took 10078 ms 2012-10-30T10:00:23.250+01:00 [03604 error 'Default'] Failed to intialize VMware VirtualCenter. Shutting down... 2012-10-30T10:00:23.250+01:00 [03604 info 'Default'] Wrote uptime information 2012-10-30T10:00:23.266+01:00 [03604 error 'Default'] Alert:false@ d:/build/ob/bora-455964/bora/vpx/vpxd/util/vpxdVdb.cpp:408 --> Backtrace: --> backtrace[00] rip 000000018013d40a (no symbol) --> backtrace[01] rip 00000001800ffa38 (no symbol) --> backtrace[02] rip 00000001800fffee (no symbol) --> backtrace[03] rip 0000000180094b8a (no symbol) --> backtrace[04] rip 000000013f648763 (no symbol) --> backtrace[05] rip 000000013ff8f5ce (no symbol) --> backtrace[06] rip 000000013ff8f7b3 (no symbol) --> backtrace[07] rip 00000001401adea7 (no symbol) --> backtrace[08] rip 000007fefedba82d (no symbol) --> backtrace[09] rip 000000007705652d (no symbol) --> backtrace[10] rip 00000000773ec521 (no symbol) --> 2012-10-30T10:00:23.266+01:00 [03604 info 'Default'] Registry Item DB 5 value is '50'
Environment
VMware vCenter Server 4.0.x VMware vCenter Server 4.1.x VMware vCenter Server 5.1.x VMware vCenter Server 5.0.x
Cause
This issue occurs if a Windows user that is configured as the Logon User in the VMware VirtualCenter Server Service no longer exists or has been deleted, or does not have sufficient administrator privileges.
Resolution
To resolve this issue, use one of these options:
Log in as an administrator.
Re-create the Windows User:
Right-click My Computer, then click Manage.
Expand Local Users and Groups.
Right-click Users and choose New User.
Provide the credentials of the intended Windows user.