Cannot log in to vMA using the Web interface or SSH
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Article ID: 309737
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Updated On:
Products
VMware vCenter Server
VMware vSphere ESXi
Issue/Introduction
- Cannot log in to vSphere Management Assistant (vMA) using the Web interface or Secure Shell (SSH).
- Logging in to vMA using the Web interface or SSH fails.
- When logging in to vMA via SSH, you see the error:
Error: Access Denied
- When logging in to vMA via Web interface, you see the error:
Error: Unable to authenticate user. Please try again.
- You are able to log in to vMA using the vMA console.
Environment
- VMware vSphere Management Assistant 4.1
- VMware vSphere Management Assistant 5.5
Cause
The issue occurs if there is a backslash (\) character in the vMA password.
Resolution
Ensure the vMA password does not include a backslash character.
To change the vMA password ensuring there is no backslash character:
- Connect to the vMA console in a vSphere Client.
- Press Alt + F2 to access the login prompt.
- Enter vi-admin for the user and enter the current password.
- In the command-line, run the command:
passwd
-
When prompted, enter a new password that does not include a backslash.
Additional Information
To troubleshoot SSH issues on the vMA:
- To determine if the sshd service is running, run the command:
# sudo service sshd status
- If the SSH service is not running, restart the service using this command:
# sudo service sshd restart
- If the issue persists even after restarting the service, open the /etc/hosts.allow file and change the sshd: ALL entry to:
sshd: ALL: ALLOW
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