Web インターフェイスまたは SSH を使用して vMA にログインできない
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Web インターフェイスまたは SSH を使用して vMA にログインできない

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Article ID: 309736

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VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

Symptoms:

免責事項: これは英文の記事 「Cannot log in to vMA using the Web interface or SSH (2011061)」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。


  • Web インターフェイスまたはセキュア シェル (SSH) を使用して vSphere Management Assistant (vMA) にログインできない。
  • Web インターフェイスまたは SSH を使用した vMA へのログインが失敗する。
  • vMA に SSH 経由でログインすると、次のエラーが表示される:

    エラー: アクセスが拒否されました

  • vMA に Web インターフェイス経由でログインすると、次のエラーが表示される:

    エラー: ユーザーを認証できません。もう一度やり直してください。

  • vMA コンソールを使用して vMA にログインできる。


Environment

VMware vSphere Management Assistant 5.5
VMware vSphere Management Assistant 4.1

Cause

この問題は、vMA パスワードにバックスラッシュ (\) 文字がある場合に発生します。

Resolution

この問題を解決するには、vMA パスワードにバックスラッシュ文字が含まれないようにします。

バックスラッシュ文字が含まれないように vMA パスワードを変更するには:
  1. vSphere Client で vMA コンソールに接続します。
  2. [Alt + F2] を押して、 ログイン プロンプトにアクセスします。
  3. ユーザーに vi-admin を入力し、 現在のパスワードを入力します。
  4. コマンドラインで、次のコマンドを実行します:

    passwd

  5. プロンプトが表示されたら、バックスラッシュを含まない新しいパスワードを入力します。


Additional Information

詳細については、『vSphere Management Assistant Guide』を参照してください。

vMA での SSH 問題をトラブルシューティングするには:
  1. sshd サービスが実行されているかどうかを判断するには、次のコマンドを実行します:

    # sudo service sshd status

  2. SSH サービスが実行されていない場合、次のコマンドを使用してサービスを再起動します:

    # sudo service sshd restart

  3. サービスを再起動しても問題が解決されない場合、/etc/hosts.allow ファイルを開き、sshd: ALL エントリを次のように変更します:
    sshd: ALL: ALLOW
Cannot log in to vMA using the Web interface or SSH