CPU usage spikes after installing VMware Tools
search cancel

CPU usage spikes after installing VMware Tools

book

Article ID: 309696

calendar_today

Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

Symptoms:
After installing or upgrading VMware Tools in a Windows virtual machine, you experience these issues on an ESX 4.x host:
  • CPU usage by the vmtoolsd.exe process spikes every few seconds.
  • Reinstalling VMware Tools does not resolve the issue.
  • In the VMware Tools log, you see this error repeatedly:

    Cannot find perfmon object in array returned by perfDLL, index=1
    Nov 11 13:51:03.774: [vmsvc]: GuestInfoMonitorReadOnePerfmonCounter fails


Environment

VMware ESX 4.0.x
VMware ESX 4.1.x
VMware vCenter Server 4.0.x
VMware vCenter Server 4.1.x

Cause

VMware Tools in ESX 4.x installs two performance objects for performance monitoring (perfmon):
  • VM memory
  • VM processor
If perfmon is not working properly or is corrupt, VMware Tools uses excess CPU cycles in an attempt to update perfmon counters.

To confirm that perfmon is causing this issue, enable VMware Tools logging in the guest operating system:

  1. Open the tools.conf file in a text editor. For more information on where to find the tools.conf file, see Enabling debug logging for VMware Tools within a guest operating system (1007873).
  2. Add this line to tools.conf:

    log.file = "c:\vmware.log"

  3. Restart the VMware Tools service (vmtoolsd.exe).
  4. Examine the VMware Tools log for the error listed in the Symptoms section.

Resolution

To resolve this issue, rebuild the performance counters using the Windows lodctr utility.

To rebuild the performance counters:
  1. Stop the VMware Tools service.
  2. Run these commands at a command prompt:

    # cd\windows\system32
    #lodctr /R


    Note: For more information about on using lodctr /R, see Microsoft Knowledge Base article 300956.

    The preceding link was correct as of May 24, 2013. If you find the link is broken, provide feedback and a VMware employee will update the link.

If the lodctr /R command does not resolve the issue:
  1. Follow the steps in Microsoft Knowledge Base article 300956.
  2. Reinstall VMware Tools.
  3. Reboot the virtual machine.

To verify that perfmon is working correctly:
  1. Launch perfmon.msc.
  2. Verify that the VMware performance objects can be loaded.
  3. Verify that perfmon shows specific object names and not numbers.


Additional Information

To disable VMware Tools logging, see Enabling debug logging for VMware Tools within a guest operating system (1007873).Enabling debug logging for VMware Tools within a guest operating system
安装 VMware Tools 后 CPU 使用率达到峰值
VMware Tools のインストール後に CPU 使用率が急増する