Performing Reset System Configuration on an ESXi host causes ASYNC drivers to revert to older version
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Performing Reset System Configuration on an ESXi host causes ASYNC drivers to revert to older version

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Article ID: 309585

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:
Performing a Reset System Configuration from the ESXi DCUI causes the latest installed ASYNC drivers to be lost on the host and reverted back to the older version.

Environment

VMware vSphere ESXi 5.0
VMware vSphere ESXi 5.1
VMware ESXi 4.1.x Embedded
VMware ESXi 4.1.x Installable

Cause

The ESXi DCUI Reset System Configuration option removes these files from the bootbank:
  • local.tgz
  • extmod.tgz
  • cimstgc.tgz

    Note: The extmod.tgz file is where updated fnic / enic ASYNC drivers reside.
Vendor drivers are stored in oem.tgz , which is not removed during the bootbank reset. When a reset is performed, updated fnic / enic drivers are removed with extmod.tgz and the host reverts to the version of the drivers included by the vendor in oem.tgz.

Resolution

This is by design, as any drivers installed on the system which are not part of the OEM install image are discarded when the host is reset to factory defaults using the Reset System Configuration option.

After the Reset System Configuration option is run, any updated ASYNC driver on the ESXi host is lost and the ESXi host reverts to the driver version which was included in the OEM image.

To install Async Drivers after a system reset, see:

ESXi 5.x, Installing async drivers on ESXi 5.x (2005205).
ESX/ESXi 4.x, Installing async drivers on ESXi 4.x and ESX 4.x (1032936).

To find out if the Async driver is installed or not on ESXi 5.x, run this command:

esxcli --server=server_name software acceptance get

In ESXi/ESX 4.x, run the esxupdate query command, check the build number of the driver and check the VMware Compatibility Guide page (under IO devices) to find out if it is an Inbox or Async driver. If you are not sure on how to find this information, contact VMware Support. For more information, see Filing a Support Request in Customer Connect (2006985).

Note: VMware recommends saving the extmod.tgz file from the bootbank directory to another location prior to resetting the system configuration. Also record the drivers and versions prior to the reset. For more information, see Determining which storage or network driver is actively being used on ESXi host (1034674).


Additional Information


Installing async drivers on ESXi 4.x and ESX 4.x
Determining which storage or network driver is actively being used on ESXi host
How to download and install async drivers in ESXi 5.x/6.x
How to file a Support Request in Customer Connect