book
Article ID: 309539
calendar_today
Updated On:
Issue/Introduction
Symptoms:
After a full install of the ESXi 5 VMware Tools:
- Copying files to or from a CIFS share takes considerably longer than before the install.
- The impact is especially noticeable if one side of the copy is not capable of SMB 2.0.
- Disabling the VMCI or the
vsepflt
driver resolves the performance issue (requires reboot). - Unloading the
vsepflt
filter resolves the performance issue (no reboot required).
Environment
VMware vSphere ESXi 5.0
VMware vShield Endpoint 5.0.x
VMware vSphere ESXi 5.1
Cause
Starting with ESXi 5.0, VMware Tools ships with the vShield Endpoint filter driver. This driver is automatically loaded when VMware Tools is installed using the Full option, rather than the Typical default.
Due to certain handling implementations in the filter driver and restrictions in the filter driver framework, file copy operations to or from a Windows network share might have noticeably impacted performance.
Resolution
This is a known issue and has been resolved in:
If you cannot update and you are not using vShield Endpoint for antivirus protection, unload the filter driver and disable it.
- Click Start > Run, type
cmd
and press Enter to open a command prompt. - To view the currently loaded filters, run the command:
C:\> fltmc
Filter Name Num Instances Altitude Frame
---------------------- ------------- ------------ -----
vsepflt 5 328200 0
luafv 1 135000 0
- To unload the
vsepflt
driver, run the command:
C:\> fltmc unload vsepflt
- To prevent the
vsepflt
driver from loading on subsequent reboots:
Note: Before making any registry modifications, ensure that you have a current and valid backup of the registry and the virtual machine. For more information on backing up and restoring the registry, see the Microsoft article 136393.
- Click Start > Run, type
regedit
, and press Enter. The Registry Editor window opens. - Navigate to:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\vsepflt
- Locate the
Start
DWORD. - Right-click
Start
and click Modify. - Change the value to
4
and click OK. - Click File > Exit to close the Registry Editor.
Note: For more information on the Services subkeys, see the Microsoft article CurrentControlSet\Services Subkey Entries.
Note: If you are using vShield Endpoint for antivirus protection, please file a support request with VMware Technical Support and note this Knowledge Base article ID (2034490) in the problem description. For more information, see
Filing a Support Request in Customer Connect (2006985).
Note: The links in this article were correct as of December 28, 2012. If you find a link is broken, provide feedback and a VMware employee will update the link.