Storage vMotion operation fails with the error: A general system error occurred: Migrate: Received request to migrate TO when already migrating 'to' (2)
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Storage vMotion operation fails with the error: A general system error occurred: Migrate: Received request to migrate TO when already migrating 'to' (2)

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Article ID: 309230

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Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • The Storage vMotion operation fails
  • The following error is reported in vCenter/vSphere client:

    A general system error occurred: Migrate: Received request to migrate TO when already migrating 'to' (2).


Environment

VMware vCenter Server 5.1.x
VMware ESXi 4.1.x Installable
VMware vCenter Server 4.1.x
VMware vCenter Server 5.0.x
VMware ESX 4.0.x
VMware ESXi 4.1.x Embedded
VMware vSphere ESXi 5.1
VMware vSphere ESXi 5.0
VMware ESXi 4.0.x Installable
VMware ESX 4.1.x
VMware vCenter Server 4.0.x
VMware ESXi 4.0.x Embedded

Cause

This issue may occur if a power-outage or a vCenter Server outage happened during a previous Storage vMotion operation. There may be a hidden Storage vMotion process running on the ESX host that prevents the new Storage vMotion task on the same virtual machine.

Resolution

To resolve this issue:
  1. The process locking the files may be one of the ESX/ESXi host management agents. Restarting them on the host running the virtual machine may resolve the issue.

    For more information on restarting the host management agents, see Restarting the Management agents on an ESX or ESXi Server (1003490).

  2. Verify if there are any files that were cloned before the outage. Browse the destination datastore and see if any files from the virtual machine have been populated.
  3. Verify that the currently running virtual machine is associating it's VMDK and VMX file(s) to the original datastore.

    1. Right-click the virtual machine and click Edit Settings.
    2. Click each hard disk and view the path of the VMDK file.
    3. Click the Options tab and verify that the VMX file is located in the source datastore.

      If your files are located on the source datastore, proceed to the next step.

  4. In the console of the ESX/ESXi host, check if there are multiple processes running for the virtual machine by searching the list of running processes using this command:

    In ESX:

    # ps -auxwww | grep -i vm_name.vmx

    In ESXi:

    # ps -c | grep -i vm_name.vmx


    If there are multiple processes running, you see an output similar to:

    root 4011 0.0 0.3 2016 860 ? S< Jun22 0:17 /usr/lib/vmware/bin/vmkload_app /usr/lib/vmware/bin/vmware-vmx -ssched.group=host/user -# name=VMware ESX Server;version=4.0.0;licensename=VMware ESX Server;licenseversion=2.0 build-158874; -@ pipe=/tmp/vmhsdaemon-0/vmx569228e44baf49d1; /vmfs/volumes/453222e30-163208d0-17c6-001f22vb3abec/<EM>VMDIR/VMNAME.vmx

  5. Locate the entry with the new datastore on which the virtual machine migration was not successful.
  6. If you do not have files associated with the new datastore path, run this command to kill the process:

    # kill -9 pid

  7. To ensure that the process was killed successfully, search the list of running processes again using this command:

    In ESX:

    # ps -auxwww | grep -i vm_name.vmx

    In ESXi:

    # ps -c | grep -i vm_name.vmx


  8. Remove the files on the destination datastore and then retry the Storage vMotion operation.


Additional Information


Restarting the Management agents in ESXi